Sign in

Chris @ Network Fun-Times

@networkfuntimes.bsky.social
626 followers 62 following 66 posts

Mr Nice-Posts. winner of official Most Handsome Network Engineer award 2029. JNCIE-SP, Juniper Networks instructor and courseware writer. Blogger at www.networkfuntimes.com. funny o nline man,

PostsRepliesMedia
Reposted by Chris @ Network Fun-Times
Gerald Combs @geraldcombs.bsky.social · 23/09/2026
#Wireshark 4.6.9 has been released. Cheers! These releases are brought to you by the Wireshark Foundation. If you or your employer can donate, it would help us out immensely. www.wireshark.org/docs/relnote... wiresharkfoundation.org/donate/
052
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 30/08/2026
Random historical MPLS thing I learned today, surprised I hadn't seen mentioned before: there was once an attempt to make a version of LDP that could do constraint-based traffic engineering. datatracker.ietf.org/doc/rfc3212/ Wikipedia says the IETF stopped progressing it in 2003 in favour of RSVP.
datatracker.ietf.org
RFC 3212: Constraint-Based LSP Setup using LDP
This document specifies mechanisms and TLVs (Type/Length/Value) for support of CR-LSPs (constraint-based routed Label Switched Path) using LDP (Label Distribution Protocol). [STANDARDS-TRACK]
152
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 18/08/2026
Another outstanding blog by my guy Bryton Herdes and his colleagues at Cloudflare (Iliana Xygkou and Mingwei Zhang) on a new-ish feature called BGP roles. By explicitly defining who is a customer, peer, and provider, route leaks can be caught and ignored early. blog.cloudflare.com/rfc9234-bgp-...
blog.cloudflare.com
BGP Role model: tracking the adoption of RFC 9234
RFC 9234 lets routers reject route leaks on their own, using BGP Roles and the Only to Customer attribute. We measured who has deployed it, and found two Tier 1 networks unexpectedly stripping OTC.
064
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 02/07/2026
Anyone know why RFC number 10000 was skipped? Is it still to come? Will it be a good one? Shall we have a house party for the big day when it goes live? We should have a house party for the big day when it goes live.
192
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 04/06/2026
Outstanding blog by Cloudflare (co-written by the excellent Bryton Herdes) on how BGP prefixes can be hijacked using peers that don't check that the first AS is also the AS advertising the prefix to that peer. The internet was architected in a more trusting era! blog.cloudflare.com/enforce-firs...
blog.cloudflare.com
Enforcing the First AS in BGP AS PATHs
BGP is vulnerable to routing hijacks and path leaks that negatively impact traffic on the Internet. RPKI helps solve some of these problems, but for some forged paths, we need to rely on a simpler mec...
061
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 28/05/2026
Great write up of a 2025 RFC that totally deprecates the BGP AS_SET path segment type. Explains what it is, why it causes security problems, and the ways that its removal enables RPKI on the entire AS_PATH. Interesting stuff. www.noction.com/blog/depreca...
noction.com
Deprecated AS_SET: Why the IETF changed the rules of BGP aggregation.
RFC 9774 prohibits AS_SET in BGP. Learn why AS_SET was deprecated, its impact on RPKI and routing security, and how to migrate to compliant aggregation.
075
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 08/03/2026
Pals, I'm looking at a Wireshark RSVP packet capture. I cannot for the life of me work out how to show the token bucket rate/size in decimal , rather than scientific notation. Does anyone know please?
261
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 22/02/2026
An IS-IS question for anyone who knows. Did pre-2005 network OSs let you turn off L1 and L2 hellos per-interface? Or were you limited only to turning off a level on the entire node? If it was possible per-interface, was the option always there from day one of IS-IS support? Or was it added later?
262
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 09/12/2025
Super interesting video about how the Japanese internet was started "illegally" in the 1980s, and some ways it had an influence on today's global internet. www.youtube.com/watch?v=kAjd...
youtube.com
How Japan’s internet started... illegally?
YouTube video by Navek
011
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 13/09/2025
Lol - I enjoyed this closing paragraph on Ivan Pepelnjak's post on reaching off-subnet nodes in IP and CLNP, talking about historical "hacks" for IPv4 hosts to auto-discover routers on a LAN: blog.ipspace.net/2025/03/comp...
030
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 25/08/2025
Some happy news: I passed the Japanese Language Proficiency Test (JLPT) N5 exam :) It's the beginners level cert. 800 words, 100 kanji (Chinese characters), 50 grammar points. Nothing difficult to most people - but 2nd languages do not come naturally to me, so it was a real challenge. I'm relieved!
2121
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 28/07/2025
I wasn't able to attend this conference, but I'm excited to watch some of these videos. Lots of great topics on offer. Take a look:
020
Reposted by Chris @ Network Fun-Times
Drew Conry-Murray @drewcm.bsky.social · 30/04/2025
A chart comparing the number of Common Vulnerabilities and Exposures (CVEs) to papal reigns. There were zero under Pius XII and 283,784 under Francis.
072
Reposted by Chris @ Network Fun-Times
bot.bgpstuff.net @bot.bgpstuff.net · 23/04/2025
I see 1000028 IPv4 prefixes. This is 240 more prefixes than 6 hours ago and 970 more than a week ago. 61.78% of prefixes are /24.
2179
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 24/04/2025
It's a few years old, but I just discovered a super cool set of gacha (Japanese capsule toys) for a miniature rack of routers and switches. A forum user called "Agg" has posted extensive photos. Well worth a look: forums.overclockers.com.au/threads/mini...
151
Reposted by Chris @ Network Fun-Times
nixCraft @cyberciti.biz · 14/04/2025
Packets that don't receive a reply to ping comnand aren't truly lost; they briefly enter a low-latency parallel dimension where time flows differently. Occasionally a stray "lost" packet will reappear days or even weeks later. This phenomenon is known as the "Lost Packet Dimension".
4603
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 18/03/2025
I love every video Cathode Ray Dude makes. His most recent one is of great interest to network engineers. He tells the history of 80s and 90s internet connectivity, exploring ISDN, leased lines, and the advent of ADSL. www.youtube.com/watch?v=ympj...
youtube.com
Five Phone Stories
YouTube video by Cathode Ray Dude - CRD
011
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 10/03/2025
In addition to the famous 2001:db8::/32, Today I learned that there's now a second IPv6 prefix that is reserved for documentation: 3fff::/20. Lol, I'm only seven months late to the party on this one! datatracker.ietf.org/doc/html/rfc...
datatracker.ietf.org
RFC 9637: Expanding the IPv6 Documentation Space
The document describes the reservation of an additional IPv6 address prefix for use in documentation. This update to RFC 3849 expands on the existing 2001:db8::/32 address block with the reservation o...
052
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 08/03/2025
Oh my, this is brilliant - someone edited an orchestra to make it sound like they’re doing a live performance of a dial-up connection. If the comments are to be trusted, it's accurate! youtu.be/wuN-bW_zS0Q?...
youtu.be
Ode to Internet - V.90 56k dialup modem handshake for orchestra
YouTube video by staybeam
074
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 26/02/2025
When you study a new skill like network engineering, as you move onto the advanced pieces, you might find you forget the basics - because you're not thinking about them as much. This is normal. You're not stupid. You're not doomed to fail. There's a lot to remember, and it's all part of the journey.
092
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 16/01/2025
I've been a fan of Japanese pop culture since 1995. Many half-hearted attempts along the way to learn the language. Recently started genuinely trying. Currently at the expert beginner stage, lol. I know enough to be dangerous, but no way near enough to be useful. Approx 150 kanji, 800 words.
120
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 15/01/2025
I received a lovely email today from someone who discovered my blog post on Class of Service (aka QoS) in Junos, and said it helped them understand the config. Well, I'll definitely use that as a chance to share the post again! Hopefully it'll help you too: www.networkfuntimes.com/how-to-read-...
networkfuntimes.com
How To Read A Junos Class-Of-Service Configuration
Struggling to read Junos Class-of-Service config? This post is for you: it shows you where to start, what order to read each piece in, and what to look for. After this you'll have no problem working o...
172
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 06/01/2025
KRAZAM is back with another brilliant sketch. This time: artisanal data collectors. www.youtube.com/watch?v=eDr6... It's joyous nonsense. Once you're done, check out their sketch "IETF Celebrates The Standards". Easily one of my favourite things on this otherwise-cursed internet. Absurd genius.
youtube.com
Small Data
YouTube video by KRAZAM
010
Reposted by Chris @ Network Fun-Times
Steve Puluka @spuluka.bsky.social · 04/01/2025
Nobody Ikes CAPTCHAs so thanks to Guillermo Rauch, who created a Doom classic video game based one where once you kill 3 monsters you are human. doom-captcha.vercel.app
doom-captcha.vercel.app
DOOM® CAPTCHA
Prove you're human by playing DOOM
001
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 28/11/2024
When folks talk about segment routing, it's often in regards traffic-engineered paths. Personally, I really like segment routing (specifically SR-MPLS) as an LDP replacement - which is to say, a full mesh of auto-created shortest-path LSPs, but with 100% topology coverage for backup paths.
282
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 22/11/2024
Considering my follower count has risen 10x, I should probably say hi! I'm Chris. I use my website to teach networking with "jokes" and "mandatory fun". I focus on Junos/Juniper, and on service provider tech (BGP/MPLS). Here's an example post you might like: www.networkfuntimes.com/a-complete-b...
networkfuntimes.com
A COMPLETE BEGINNER'S GUIDE TO SUBNETTING
If you're a newcomer to networking, chances are you're struggling to get your head around subnet masks. Well don't worry: your goth uncle is here to explain how it all works. CCNA and JNCIA/JNCIS stud...
3177
Reposted by Chris @ Network Fun-Times
Max Read @maxread.info · 25/09/2024
For New York mag, I wrote about the slop economy nymag.com/intelligence...
19596264
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 17/09/2024
The IETF working group for IPv6 maintenance is called 6man. Despite my repeated emails, they REFUSE to acknowledge whether 6man is related to Five Guys. Reader, I promise you: I will not let them dodge this question.
254
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 16/09/2024
NEW POST: After many months of work, my four-day instructor-led SR-MPLS course is now live! Plus, Krzysztof Szarkowicz has written some great blogs introducing SRv6. Want to find out more? Clicky-click: www.networkfuntimes.com/my-new-sr-mp...
networkfuntimes.com
My New SR-MPLS Course, and Krzysztof's SRv6 Blogs
My new four-day instructor-led SR-MPLS course is now live! In addition, my colleague Krzysztof Szarkowicz has written many free blog posts on SRv6. Click this post to find out all about it.
043
Reposted by Chris @ Network Fun-Times
Mary Gillis @marygillis.bsky.social · 26/07/2024
Musk is a thieving little shit. Automatically signing everyone up to the "steal my work" setting, not notifying users, and hiding the opt-out so you can't even do it on the app.
0195
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 16/05/2024
Jeff and Drew! What a combo. I extremely highly recommend that you sign up to this.
111
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 01/05/2024
Lol so I don't know if this is common in math(s) or not, but the original spec for the shortest-path first (SPF) algorithm in 1978 used the term "son" and "father" to describe one node going to another apps.dtic.mil/sti/pdfs/ADA...
100
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 06/04/2024
"Fun" game: If you ever study SR, look out for the phrase "Segment Routing leverages the source routing paradigm". It's the first sentence of many RFCs—and it also appears in *tons* of vendor docs, blogs, training, etc. One person wrote it, and countless many others have copy-pasted it exactly.
020
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 24/03/2024
Today I polished up my two-part intro to MPLS segment routing. I added some new facts, corrected some mistakes, and made it a little bit tighter. If you're curious about SR-MPLS, now is a very fine time to give it a read! Here's Part 1: www.networkfuntimes.com/mpls-segment...
networkfuntimes.com
MPLS Segment Routing, Part 1: The Theory (Beginner's Guide)
Every year, more folks are talking abouts segment routing for MPLS. Want to know what the fuss is about? Start here! This post gives you the high-points of some of the most important parts of the theo...
020
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 02/03/2024
At the request of no-one, I have joined yet another hell website. Did you know that there are more IPv6 addresses than there are people in Chicago? It's true! Try counting them if you don't believe me. Follow me for more networking facts. Or, don't. Your poor choices are your own to make.
1181