Sign in

Chris @ Network Fun-Times

@networkfuntimes.bsky.social
631 followers 62 following 66 posts

Mr Nice-Posts. winner of official Most Handsome Network Engineer award 2029. JNCIE-SP, Juniper Networks instructor and courseware writer. Blogger at www.networkfuntimes.com. funny o nline man,

PostsRepliesMedia
Reposted by Chris @ Network Fun-Times
Gerald Combs @geraldcombs.bsky.social · 23/09/2026
#Wireshark 4.6.9 has been released. Cheers! These releases are brought to you by the Wireshark Foundation. If you or your employer can donate, it would help us out immensely. www.wireshark.org/docs/relnote... wiresharkfoundation.org/donate/
062
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 30/08/2026
Indeed - and on the flipside, so many small decisions made 30 years ago when networking looked totally different & routers had the RAM of a peanut, the reasoning lost to the sands of time, and then in 2026 we look at the protocol design & go "lol, 10 second timers? What were they thinking?!"
110
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 30/08/2026
Random historical MPLS thing I learned today, surprised I hadn't seen mentioned before: there was once an attempt to make a version of LDP that could do constraint-based traffic engineering. datatracker.ietf.org/doc/rfc3212/ Wikipedia says the IETF stopped progressing it in 2003 in favour of RSVP.
datatracker.ietf.org
RFC 3212: Constraint-Based LSP Setup using LDP
This document specifies mechanisms and TLVs (Type/Length/Value) for support of CR-LSPs (constraint-based routed Label Switched Path) using LDP (Label Distribution Protocol). [STANDARDS-TRACK]
152
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 18/08/2026
Another outstanding blog by my guy Bryton Herdes and his colleagues at Cloudflare (Iliana Xygkou and Mingwei Zhang) on a new-ish feature called BGP roles. By explicitly defining who is a customer, peer, and provider, route leaks can be caught and ignored early. blog.cloudflare.com/rfc9234-bgp-...
blog.cloudflare.com
BGP Role model: tracking the adoption of RFC 9234
RFC 9234 lets routers reject route leaks on their own, using BGP Roles and the Only to Customer attribute. We measured who has deployed it, and found two Tier 1 networks unexpectedly stripping OTC.
064
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 13/08/2026
Please tell this to the local hooligans who REFUSE to stop calling me "potato boy" as they throw a variety of potato cultivars are me (King Edward, Maris Bard, Sharpes Express, Belle de Fonteney, etc)
020
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 13/08/2026
That makes me very happy to hear! Omg I hope there's no mistakes in it, I should probably go back and give it a proof-read sometime. Awesome to hear you're training up other people in your work - how's that process going?
030
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 03/07/2026
I ask the questions everyone is too scared to ask. Or, that they can't be bothered to ask. Or, that they don't care about. Either way, I'm asking it.
020
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 03/07/2026
Aah, good to know, thank you. I'll keep a keen eye out for the day that www.rfc-editor.org/info/rfc10000/ doesn't return a 404 error.
rfc-editor.org
010
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 02/07/2026
Anyone know why RFC number 10000 was skipped? Is it still to come? Will it be a good one? Shall we have a house party for the big day when it goes live? We should have a house party for the big day when it goes live.
192
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 01/07/2026
I am inviting all of my followers to send me 17p or 14¢, whichever is bigger. I will use this money to wreak vengeance upon all who have crossed me. If there's any money left over, I'll buy some blueberries (trying to eat more healthy snacks atm)
170
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 04/06/2026
Outstanding blog by Cloudflare (co-written by the excellent Bryton Herdes) on how BGP prefixes can be hijacked using peers that don't check that the first AS is also the AS advertising the prefix to that peer. The internet was architected in a more trusting era! blog.cloudflare.com/enforce-firs...
blog.cloudflare.com
Enforcing the First AS in BGP AS PATHs
BGP is vulnerable to routing hijacks and path leaks that negatively impact traffic on the Internet. RPKI helps solve some of these problems, but for some forged paths, we need to rely on a simpler mec...
061
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 28/05/2026
Great write up of a 2025 RFC that totally deprecates the BGP AS_SET path segment type. Explains what it is, why it causes security problems, and the ways that its removal enables RPKI on the entire AS_PATH. Interesting stuff. www.noction.com/blog/depreca...
noction.com
Deprecated AS_SET: Why the IETF changed the rules of BGP aggregation.
RFC 9774 prohibits AS_SET in BGP. Learn why AS_SET was deprecated, its impact on RPKI and routing security, and how to migrate to compliant aggregation.
075
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 08/03/2026
Yeah man, will do. :)
000
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 08/03/2026
Pals, I'm looking at a Wireshark RSVP packet capture. I cannot for the life of me work out how to show the token bucket rate/size in decimal , rather than scientific notation. Does anyone know please?
261
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 07/03/2026
I've sometimes say I'm an IP Engineer rather than a Network Engineer - because working in the ISP space, there was always a separate team that did all the Layer 1 and the racking and stacking. My cabling knowledge has always been extremely basic - and then I forget it, because I never use it.
120
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 06/03/2026
Andy Lapteff.
020
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 23/02/2026
Thanks for looking that up! Interesting, interesting. This all helps with a theory I have that I might turn into a blog post. Sincerely grateful to you for finding that! You have a far better memory than me.
010
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 23/02/2026
Interesting, thank you. I think the config you're remembering is " isis circuit-type level-1" or 2 or 1-2 on the interface. I don't suppose you know enough about their documentation to know how to find what OS version the command was introduced please?
100
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 23/02/2026
Apologies, I'm not quite sure what piece of info in that link you're pointing me to?
000
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 22/02/2026
An IS-IS question for anyone who knows. Did pre-2005 network OSs let you turn off L1 and L2 hellos per-interface? Or were you limited only to turning off a level on the entire node? If it was possible per-interface, was the option always there from day one of IS-IS support? Or was it added later?
262
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 09/12/2025
I cheated on my JNCIE-SP by "trying to memorize as many pieces of information as I could before I sat the exam". Plz don't tell anyone.
140
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 09/12/2025
Super interesting video about how the Japanese internet was started "illegally" in the 1980s, and some ways it had an influence on today's global internet. www.youtube.com/watch?v=kAjd...
youtube.com
How Japan’s internet started... illegally?
YouTube video by Navek
011
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 17/09/2025
have u checked that the baud rate flow control is correct ?
000
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 13/09/2025
Lol - I enjoyed this closing paragraph on Ivan Pepelnjak's post on reaching off-subnet nodes in IP and CLNP, talking about historical "hacks" for IPv4 hosts to auto-discover routers on a LAN: blog.ipspace.net/2025/03/comp...
030
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 25/08/2025
Thank you mate! :)
110
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 25/08/2025
It reminds me of that when I first passed my CCNA 18 years ago, in that I know I've passed - but the knowledge isn't truly locked in yet. It feels like a fierce gust of wind could blow all the facts right out of my brain, lol. It'll be another year of study until I feel like I'm truly at N5 level.
030
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 25/08/2025
Some happy news: I passed the Japanese Language Proficiency Test (JLPT) N5 exam :) It's the beginners level cert. 800 words, 100 kanji (Chinese characters), 50 grammar points. Nothing difficult to most people - but 2nd languages do not come naturally to me, so it was a real challenge. I'm relieved!
2121
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 07/08/2025
I like that the keyboard in this picture replaces the W and I keys with additional letter As. This is a great efficiency, because A is a really common letter, whereas W and I are basically useless. I personally never use those weird garbage letters.
010
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 28/07/2025
I wasn't able to attend this conference, but I'm excited to watch some of these videos. Lots of great topics on offer. Take a look:
020
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 11/06/2025
Oh so ur a CCIEx2? Prove it - name five IPs. I'll wait
010
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 10/06/2025
Yeah. Looks like one block, but really it's many smaller blocks. Some orgs even have multiple blocks that are totally different - just depends on what was available at the time. Having said that, I bet your script could query WHOIS to find out precisely what blocks are owned.
000
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 03/06/2025
Hi! I see that an org called Primus Telecommunications Canada owns those IPs. It's not one single block—it's built out of multiple other subnets. See attached pic. So, in terms of subnetting, there's no way to tell that the 21.0 block comes first. You have to do a whois to find the details.
100
Reposted by Chris @ Network Fun-Times
Drew Conry-Murray @drewcm.bsky.social · 30/04/2025
A chart comparing the number of Common Vulnerabilities and Exposures (CVEs) to papal reigns. There were zero under Pius XII and 283,784 under Francis.
072
Reposted by Chris @ Network Fun-Times
bot.bgpstuff.net @bot.bgpstuff.net · 23/04/2025
I see 1000028 IPv4 prefixes. This is 240 more prefixes than 6 hours ago and 970 more than a week ago. 61.78% of prefixes are /24.
2179
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 24/04/2025
It's a few years old, but I just discovered a super cool set of gacha (Japanese capsule toys) for a miniature rack of routers and switches. A forum user called "Agg" has posted extensive photos. Well worth a look: forums.overclockers.com.au/threads/mini...
151
Reposted by Chris @ Network Fun-Times
nixCraft @cyberciti.biz · 14/04/2025
Packets that don't receive a reply to ping comnand aren't truly lost; they briefly enter a low-latency parallel dimension where time flows differently. Occasionally a stray "lost" packet will reappear days or even weeks later. This phenomenon is known as the "Lost Packet Dimension".
4603
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 18/03/2025
I love every video Cathode Ray Dude makes. His most recent one is of great interest to network engineers. He tells the history of 80s and 90s internet connectivity, exploring ISDN, leased lines, and the advent of ADSL. www.youtube.com/watch?v=ympj...
youtube.com
Five Phone Stories
YouTube video by Cathode Ray Dude - CRD
011
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 10/03/2025
In addition to the famous 2001:db8::/32, Today I learned that there's now a second IPv6 prefix that is reserved for documentation: 3fff::/20. Lol, I'm only seven months late to the party on this one! datatracker.ietf.org/doc/html/rfc...
datatracker.ietf.org
RFC 9637: Expanding the IPv6 Documentation Space
The document describes the reservation of an additional IPv6 address prefix for use in documentation. This update to RFC 3849 expands on the existing 2001:db8::/32 address block with the reservation o...
052
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 08/03/2025
Oh my, this is brilliant - someone edited an orchestra to make it sound like they’re doing a live performance of a dial-up connection. If the comments are to be trusted, it's accurate! youtu.be/wuN-bW_zS0Q?...
youtu.be
Ode to Internet - V.90 56k dialup modem handshake for orchestra
YouTube video by staybeam
074
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 26/02/2025
When you study a new skill like network engineering, as you move onto the advanced pieces, you might find you forget the basics - because you're not thinking about them as much. This is normal. You're not stupid. You're not doomed to fail. There's a lot to remember, and it's all part of the journey.
092
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 22/01/2025
they're all cowards &and i could easily defeat aNY of them in my dojo of death. (apart from the strong ones, and probably also the medium-strength ones)
000
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 16/01/2025
Started in Sept last year. Amazing to look back & see how far I've come. At the same time, I feel very overwhelmed at the awareness of the sheer quantity of stuff that I need to learn for even a basic-useful command of the language. Got to keep reminding myself that it's a marathon, not a sprint.
030
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 16/01/2025
I've been a fan of Japanese pop culture since 1995. Many half-hearted attempts along the way to learn the language. Recently started genuinely trying. Currently at the expert beginner stage, lol. I know enough to be dangerous, but no way near enough to be useful. Approx 150 kanji, 800 words.
120
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 15/01/2025
Oh damn, I was supposed to write more of those but then I got distracted! I'm happy that the few articles I did write were helpful though. Please tell the United Nations so they can give me awards/prizes etc.
110
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 15/01/2025
I received a lovely email today from someone who discovered my blog post on Class of Service (aka QoS) in Junos, and said it helped them understand the config. Well, I'll definitely use that as a chance to share the post again! Hopefully it'll help you too: www.networkfuntimes.com/how-to-read-...
networkfuntimes.com
How To Read A Junos Class-Of-Service Configuration
Struggling to read Junos Class-of-Service config? This post is for you: it shows you where to start, what order to read each piece in, and what to look for. After this you'll have no problem working o...
172
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 06/01/2025
KRAZAM is back with another brilliant sketch. This time: artisanal data collectors. www.youtube.com/watch?v=eDr6... It's joyous nonsense. Once you're done, check out their sketch "IETF Celebrates The Standards". Easily one of my favourite things on this otherwise-cursed internet. Absurd genius.
youtube.com
Small Data
YouTube video by KRAZAM
010
Reposted by Chris @ Network Fun-Times
Steve Puluka @spuluka.bsky.social · 04/01/2025
Nobody Ikes CAPTCHAs so thanks to Guillermo Rauch, who created a Doom classic video game based one where once you kill 3 monsters you are human. doom-captcha.vercel.app
doom-captcha.vercel.app
DOOM® CAPTCHA
Prove you're human by playing DOOM
001
Chris @ Network Fun-Times @networkfuntimes.bsky.social · 03/01/2025
The world wide web was a mistake.
140