Sign in

Aaron Parecki

@aaronpk.com
2K followers 133 following 266 posts

#OAuth #IndieWeb

PostsRepliesMedia
Aaron Parecki @aaronpk.com · 19/05/2026
my head feels like a blender that has been filled past the "do not fill above" line
020
Aaron Parecki @aaronpk.com · 30/03/2026
Found my todo list for 2026 kylegabriel.com/projects/202...
kylegabriel.com
Automated Hydroponic System Build – Projects | Kyle Gabriel
020
Aaron Parecki @aaronpk.com · 30/03/2026
TIL about UIScreenshotService which enables iOS apps to provide a high res PDF screenshot of the app content when the user uses the system screenshot action! Chrome uses this to give a full export of the page!
040
Aaron Parecki @aaronpk.com · 25/03/2026
I'm impressed, Cathay Pacific transferred my vegetarian meal request to the new flight they moved me to after the incoming flight was late and missed the connection. Normally airlines say oh well you didn't reserve the meal 72 hours before the flight.
030
Aaron Parecki @aaronpk.com · 08/03/2026
Happy final Daylight Savings Time Eve to all our friends in British Columbia! I hope we can join you on the other side soon!
041
Aaron Parecki @aaronpk.com · 06/03/2026
I'm setting up a temporary laptop for my next trip and it's shocking how much faster the cross-device passkey flow is compared to looking up and hand typing my long 1Password passwords
071
Aaron Parecki @aaronpk.com · 13/02/2026
Inspired by some #indieweb folks creating /caw pages on their websites, I made one of my own! Here you can listen to the most recent crow recorded from my house: aaronparecki.com/caw/
aaronparecki.com
Caw
030
Aaron Parecki @aaronpk.com · 27/01/2026
Apparently I missed the introduction of the 4.4mm TRRRS audio jack 10 years ago and just now discovered it. What a cool idea.
010
Aaron Parecki @aaronpk.com · 13/01/2026
"I'll just check my critical thinking and nuke it in the microwave" has to be my favorite quote from this Business Insider video on Trader Joe's white-labeled food
110
Aaron Parecki @aaronpk.com · 12/01/2026
Me looking at my todo list on a Sunday night after having done at least a couple things today, yet somehow it looks more like a list of what I did *not* do today.
010
Aaron Parecki @aaronpk.com · 17/12/2025
oh no, due to a series of misclicks, I just accidentally archived the most recent 100 emails in my inbox. if nothing else, reviewing my "all mail" folder is doing a good job of making me question how important emails in my inbox actually are.
040
Aaron Parecki @aaronpk.com · 25/11/2025
The new MCP spec just dropped! 🎉 There's too many new things to get into everything, but there are two big changes I am most excited about 👀 📝 Client ID Metadata Documents (CIMD) - a simpler way to manage client registrations, clients describe themselves with a URL they control
125
Aaron Parecki @aaronpk.com · 11/10/2025
I just finished adding BlueSky support to IndieLogin.com! Now you can log in to websites like indieweb.org with your BlueSky handle!
aaronparecki.com
Adding Support for BlueSky to IndieLogin.com
Today I just launched support for BlueSky as a new authentication option in IndieLogin.com!
48518
Aaron Parecki @aaronpk.com · 11/10/2025
The IETF OAuth Working Group has adopted the Client ID Metadata Document specification! > This specification defines a mechanism through which an OAuth client can identify itself to authorization servers, without prior dynamic client registration or other existing registration.
1535
Aaron Parecki @aaronpk.com · 20/09/2025
The IETF OAuth Working Group has adopted the Identity Assertion Authorization Grant specification! datatracker.ietf.org/doc/draft-ie... This is the basis of Cross App Access (XAA), providing IT admins better visibility and control by configuring the app-to-app connections in their enterprise IdP.
datatracker.ietf.org
Identity Assertion Authorization Grant
This specification provides a mechanism for an application to use an identity assertion to obtain an access token for a third-party API by coordinating through a common enterprise identity provider us...
164
Aaron Parecki @aaronpk.com · 20/09/2025
Inspired by a question from @thisismissem.social, I wrote up a document describing how to apply DPoP (RFC9449) to the OAuth Device Flow (RFC8628). datatracker.ietf.org/doc/draft-pa...
datatracker.ietf.org
DPoP for the OAuth 2.0 Device Authorization Grant
The OAuth 2.0 Device Authorization Grant [RFC8628] is an authorization flow for devices with limited input capabilities. Demonstrating Proof of Possession (DPoP) [RFC9449] is a mechanism to sender-con...
030
Aaron Parecki @aaronpk.com · 05/08/2025
Well that's the last time I take my ID out of my wallet to go through airport security. I made the mistake of putting it into my pocket instead of back in my wallet and it seems to have fallen out somewhere between PDX and SFO 🫠
250
Aaron Parecki @aaronpk.com · 30/06/2025
I just got FreePBX up and running and connected to a WiFi phone and my doorbell and video intercom system! I have two way calling between every device, I can even connect analog phones!
220
Aaron Parecki @aaronpk.com · 19/06/2025
The latest version of the MCP spec is now officially 2025-06-18! Congrats to everyone in the MCP community involved in making this happen! Key updates to the authorization section 👇
155
Aaron Parecki @aaronpk.com · 06/06/2025
TIL the point up emoji ☝️ doesn't work as a reaction on iMessage because Apple displays the emoji above the message it's a reaction to 😂
231
Aaron Parecki @aaronpk.com · 09/05/2025
In two weeks I'll be speaking at @mcpdevsummit.bsky.social in San Francisco! MCP has quickly reshaped how developers are building AI agents. My talk "Intro to OAuth for MCP Servers" will cover the basics of the MCP authorization protocol and set the stage for building secure MCP servers.
mcpdevsummit.ai
MCP Developers Summit - San Francisco - 2025
030
Reposted by Aaron Parecki
MCP Developers Summit @mcpdevsummit.ai · 02/05/2025
🎤 Speaker Spotlight: Aaron Parecki, Director of Identity Standards at @okta Learn how #OAuth applies to #MCP servers and why securing your #MCP server is critical To attend this session and more register at buff.ly/NzqdbNE @aaronpk.com #AI #LLM #ModelContextProtocol #MCPDevSummit
011
Aaron Parecki @aaronpk.com · 14/04/2025
oh no I just realized tomorrow is Monday
250
Aaron Parecki @aaronpk.com · 02/04/2025
Is it just me or does this current Model Context Protocol wave remind anyone of the early Web 2.0 days of everyone launching open APIs?
240
Aaron Parecki @aaronpk.com · 28/03/2025
I've got 22 hours in Hong Kong on a layover and I'm staying overnight in a hotel near the old Kowloon Walled City. Any tips for what I should do on this very short trip?
010
Aaron Parecki @aaronpk.com · 28/03/2025
The building that collapsed from the earthquake was right next to the train station we got off at when we arrived in Bangkok last weekend. We took the train from Chiang Mai to Chatuchak 😮
140
Aaron Parecki @aaronpk.com · 16/02/2025
Chase sends 8-digit 2fa SMS codes, which seems excessive compared to the 6 that most other places use, but even weirder is that the first digit of them has always been the same, effectively making it a 7 digit code. Anyone know what's up with that?
120
Aaron Parecki @aaronpk.com · 04/02/2025
At long last, the OAuth working group has finished the Best Current Practice for OAuth 2.0 Security and it was just published as RFC9700! This has been a long time in the works, and I'm very thankful to everyone who has helped out with it over the years! www.rfc-editor.org/rfc/rfc9700....
rfc-editor.org
RFC 9700: Best Current Practice for OAuth 2.0 Security
This document describes best current security practice for OAuth 2.0. It updates and extends the threat model and security advice given in RFCs 6749, 6750, and 6819 to incorporate practical experience...
24313
Aaron Parecki @aaronpk.com · 03/02/2025
Every now and then I remember how in 2014 I mined $20 worth of dogecoin, then said this is stupid and exchanged it for 0.05 bitcoin sent to a brainwallet. I can't remember the seed phrase, so it's just stuck in the blockchain, and is now worth $5000
160
Aaron Parecki @aaronpk.com · 01/02/2025
I am still getting monthly emails saying I have a $0 balance from the tenant portal of the apartment we moved out of 18 months ago. Today I logged in to see if I can delete my account, but instead I see new maintenance requests from the last few months 😮
010
Aaron Parecki @aaronpk.com · 04/01/2025
Goodbye Philips Hue 👋 I finally finished replacing all my Hue lights with Caseta switches. While I will miss the color temperature control, I am excited that I can attach a switch anywhere that works and looks just like a normal switch, no wires needed!
230
Aaron Parecki @aaronpk.com · 03/01/2025
Just made eight weeks of waffles, going into the freezer now. Took almost 2 hours to cook the 8 batches. I should really get a second waffle iron cause it would literally halve the amount of time this takes.
240
Aaron Parecki @aaronpk.com · 26/12/2024
We still don't have power from the street yet so in the mean time, I wired an Anker battery into the breaker panel to power all the lights in the house
250
Aaron Parecki @aaronpk.com · 23/12/2024
It just occurred to me that YouTube is named after a completely obsolete technology
330
Aaron Parecki @aaronpk.com · 09/12/2024
I really need to remember to put my phone on do not disturb when I'm doing electrical work. The buzz on my leg freaks me out every time ⚡️
070
Aaron Parecki @aaronpk.com · 07/12/2024
The new iOS app icons dark mode is really messing with my brain. I can't recognize any of the icons at a glance anymore, it's like having to re-learn all the branding.
170
Aaron Parecki @aaronpk.com · 03/12/2024
Just installed my first Lutron Caseta switch. Going to slowly convert all these switches over in the next few weeks. I do like how the switch is silent, no sound of a relay snapping.
250
Aaron Parecki @aaronpk.com · 29/11/2024
I still highly recommend the Pilot Institute Part 107 course if you've been thinking about getting a drone pilot license! There's a good black friday deal on right now too! pilotinstitute.com/course/part-...
pilotinstitute.com
Part 107 Commercial Drone Pilot License Course - Pilot Institute
This Part 107 course is 15 hours and it has everything you need to pass the drone license test. Plus it comes with a 30-day money-back guarantee.
020
Aaron Parecki @aaronpk.com · 27/11/2024
I've been digitizing old family VHS and 8mm tapes, and it's kind of incredible to think about how I can have a giant pile of tapes reduced to a single SD card. But also it's fun to find things like me playing piano at Nordstrom during the holidays.
160
Aaron Parecki @aaronpk.com · 24/11/2024
Tonight was batch cooking night. Just made ~50 high-protein vegan waffles and then vacuum packed them. Five minutes in the air fryer is a nice quick breakfast later!
2150
Aaron Parecki @aaronpk.com · 14/11/2024
Well this was a first. Got to the airport and realized I was sitting at the gate in so much back pain that I cancelled my flight 10 minutes before boarding and went back home. The gate agents were confused about why my cancel request was so simple.
270
Reposted by Aaron Parecki
Lillian Karabaic @anomalily.net · 14/11/2024
I have not owned a car my whole life, and consider myself a very confident bike commuter. Worked in bike shops, biked in dozens of countries. I feel like a n00b every time I try to research e-bikes. There is so much information, and so many new terms. Tell me what (budget) e-bike to get 😭
981
Aaron Parecki @aaronpk.com · 04/11/2024
I should know better than to send an email asking if I should do "a or b", because of course the response was "yes please"
050
Aaron Parecki @aaronpk.com · 04/11/2024
I don't want to speak too soon, but so far I slept a solid 8 hours last night and didn't get tired during the mid morning slump, so I think I may have avoided jet lag entirely this trip! #travel
040
Aaron Parecki @aaronpk.com · 04/11/2024
Perfect weather forecast, I'll feel right at home here this week #dublin
000
Aaron Parecki @aaronpk.com · 24/10/2024
I decided I would appreciate being home at 9:30am instead of 5pm more than I will be annoyed at having to wake up at 4:30am, so I changed my flight home to the early flight. Hope I don't oversleep! #travel
020
Aaron Parecki @aaronpk.com · 19/10/2024
Good morning ✈️🌅
030
Reposted by Aaron Parecki
bryan newbold @bnewbold.net · 25/09/2024
We got a blog post out summarizing our launch of OAuth for AT Protocol, and what work remains. This has been a huge project led by @matthieu.bsky.team with input from a bunch of standards folks and devs. Big milestone for building all sorts of clients, apps, and integrations on atproto.
docs.bsky.app
OAuth for AT Protocol | Bluesky
We are very happy to release the initial specification of OAuth for AT Protocol! This is expected to be the primary authentication and authorization system between atproto client apps and PDS instance...
8408110
Aaron Parecki @aaronpk.com · 26/09/2024
Congrats to BlueSky for launching OAuth support for apps! 🙌 docs.bsky.app/blog/oauth-a...
docs.bsky.app
OAuth for AT Protocol | Bluesky
We are very happy to release the initial specification of OAuth for AT Protocol! This is expected to be the primary authentication and authorization system between atproto client apps and PDS instance...
4305
Aaron Parecki @aaronpk.com · 09/08/2024
Someone broke through the chain link fence last week, in broad daylight, while I was home, and didn't notice at the time. I started thinking about what I could do about it, and it turns out the EA Unifi cameras have a new webhook feature.
110