Sign in

Justin Vasel

@justinvasel.xyz
453 followers 268 following 2.1K posts

Physics Ph.D. Supernova hunter. Air Force space operational energy analyst. Chair of the Bloomington Commission on Sustainability and Resilience. IU Alumn. HAM radio KE9DTH.

PostsRepliesMedia
Reposted by Justin Vasel
Cassidy @cassidoo.co · 11h
Get a library card If you have one already: use it
313323
Justin Vasel @justinvasel.xyz · 14h
Let's go Brewers!! #NCLS
static.klipy.com
Alt: The Milwaukee Brewers mascot waving the Brewers flag
000
Justin Vasel @justinvasel.xyz · 22h
bsky.app/profile/just...
010
Reposted by Justin Vasel
Jennifer Szalai @jenszalai.bsky.social · 08/10/2026
It was a short call, Carlberg said: All the poet would say was she
was "in Iceland," where she was
"listening to the wind."
361820352
Reposted by Justin Vasel
Randall Munroe @xkcd.com · 07/10/2026
Spectrum Allocation xkcd.com/3307/
Comic: Modern Spectrum Allocation Chart. [Long line of rectangles of different widths in shades of gray. From top to bottom: radio (shouting), TV test patterns, 1G cellular, radio (music), radio (static), reserved for zeppelin navigation, TV channels 2, 5, 7-13, 16, 17, and 28 with 2G cellular in between, interference, WKRP in Cincinnati, spaceship beeps, all other TV, car dealership ads, numbers stations, weather balloons, amateur radio, HAM radio, “weather balloons”, *Choosing Texas* 24/7, [extra large rectangle] boat captains say they need this for something and we don’t ask what because they’re scary, the secret radio waves that make planes stay up, defunct satellite phone company, radioastronomy, radioastrology, [extra small rectangle] all modern wireless infrastructure, death rays, LoFi hip hop beats to relax/study to, security guard walkie talkies, amateur military satellites, left open in case aliens try to call, one brand of garage door openers with a lot of political pull.]
663440610
Justin Vasel @justinvasel.xyz · 07/10/2026
Additional Reading:
joelonsoftware.com
The Absolute Minimum Every Software Developer Absolutely, Positively Must Know About Unicode and Character Sets (No Excuses!)
Ever wonder about that mysterious Content-Type tag? You know, the one you’re supposed to put in HTML and you never quite know what it should be? Did you ever get an email from your friends in…
000
Justin Vasel @justinvasel.xyz · 07/10/2026
I love seeing plain text acknowledged as a technology, because it truly is! It seems simple at first glance, but representing text digitally is a surprisingly complex challenge. So much so that it has been summed up simply as "there is no such thing as plain text."
youtube.com
Plain Text - Dylan Beattie - NDC Copenhagen 2022
YouTube video by NDC Conferences
210
Reposted by Justin Vasel
Justin Vasel @justinvasel.xyz · 26/08/2019
IS YOUR CHILD TEXTING ABOUT NEUTRINO PHYSICS? LMAO = Lepton Mixing And Oscillation WTF = What's The Flavor? BRB = Bad, ROOT! Bad! TFW = That Force is Weak NP = Nobel Prize SMH = Solve Mass Hierarchy, or Standard Model Higgs, depending on the context.
021
Justin Vasel @justinvasel.xyz · 06/10/2026
Another neutrino Nobel Prize in the books!! 🏅🌌
000
Reposted by Justin Vasel
Randall Munroe @xkcd.com · 02/10/2026
Ground Effect xkcd.com/3305/
Comic. [Two people flailing high in the air. Three people on the ground running ahead of them. Arrows and a dotted line indicate that this second group is within roughly one body length of the surface.] [caption] The “ground effect” explains why sprinters can run most efficiently if they stay within roughly one body length of the surface.
263686329
Reposted by Justin Vasel
Emily M. Bender @emilymbender.bsky.social · 30/09/2026
There's a long discussion going on in my mentions about whether or not "LLMs" (quotes explained in a sec) apparently getting mostly* correct answers to arithmetic questions is "inconsistent" with the stochastic parrots metaphor. >>
411728
Reposted by Justin Vasel
Steve Gale @stevewg.bsky.social · 22/09/2026
Colley Hill, Surrey: coffee break from birding the steep scrub. Love the plaque on the bench I’m sitting on
4397421240
Justin Vasel @justinvasel.xyz · 07/09/2026
Ricole
001
Reposted by Justin Vasel
LZ Dark Matter @lzdarkmatter.bsky.social · 01/09/2026
Our new results are out! We have observed a single nuclear recoil in our detector that we find difficult to explain with our background model. Could it be a hint of dark matter? It’s far too early to say, but it’s certainly intriguing! #darkmatter
24720
Reposted by Justin Vasel
By Cory Doctorow (GPG 0xBF3D9110957E5F4C) @doctorow.pluralistic.net · 26/08/2026
They disinvented the VCR. You might think that the reason we don't have VCRs anymore is because VCRs were supplanted by DVDs, PVRs and streaming, but that's not the case. They had it in for the VCR from the very start, and they never stopped trying to kill it. Eventually, they succeeded. 1/
A 1960s family living room in which a mom, dad and two kids are mesmerized by a cabinet-style TV. The image has been altered. The TV has an early 1990s VCR atop it. The TV screen is displaying a cross-sectioned human head with brains and spine on display. A huge fist has materialized in the room, with bloody spiked knuckle-dusters, smashing into the VCR. The oil painting over the sofa has been replaced with a pulp image of a male head, its cranium removed and replaced by a dome. Inside the dome is a red eight-segment VCR clock, displaying 12:00. The background in the painting is a tangle of cassette tape. The whole image's colors have been boosted, giving it an overexposed look.
311380589
Reposted by Justin Vasel
Library of Congress @librarycongress.bsky.social · 25/08/2026
The Library is devastated to learn of the passing of Dolly Parton, a music legend and titan of children's literacy. Her Imagination Library program has earned multiple Library Literacy Awards and, in 2018, she visited us to donate its 100 millionth book to our collection and host a story time. 🦋❤️
Dolly Parton reads to children in the Library’s Great Hall in 2018. Photo by Shawn Miller.
194335047162
Justin Vasel @justinvasel.xyz · 24/08/2026
Despite the .ai domain, this wonderful site is all about the human touch. Palette cleanser for anyone feeling nostalgic or feeling too 2026.
museum.parallel.ai
Museum of the Human Web
The Museum of the Human Web preserves the cultural artifacts that shaped internet history.
000
Reposted by Justin Vasel
Ben Cotton (he/him) @funnelfiasco.bsky.social · 21/08/2026
It's `sudo shutdown -h now` o'clock
2122
Justin Vasel @justinvasel.xyz · 21/08/2026
Poke around the internet a bit and you'll find lots of easter eggs using the 418 status code, but that is left as an exercise for the reader. A good starting place is Google's teapot page (click the teapot). www.google.com/teapot
Screenshot of google.com/teapot. The page is mostly blank. In the center is the google logo above the text: "418. I'm a teapot. The requested entity body is short and stout. Tip me over and pour me out." To the right is a whimsical light-blue sketch of a teapot with a smiling face and a teacup.
010
Justin Vasel @justinvasel.xyz · 21/08/2026
For now, HTTP code 418 is considered unused and unavailable for other applications. For now...
[RFC2324] was an April 1 RFC that lampooned the various ways HTTP was abused; one such abuse was the definition of an application-specific 418 status code, which has been deployed as a joke often enough for the code to be unusable for any future use.

Therefore, the 418 status code is reserved in the IANA HTTP Status Code Registry. This indicates that the status code cannot be assigned to other applications currently. If future circumstances require its use (e.g., exhaustion of 4NN status codes), it can be re-assigned to another use.
110
Justin Vasel @justinvasel.xyz · 21/08/2026
At one point, the HTTP Working Group noticed that 418 was the first unused status code and eyed it up for future uses. This triggered the Save 418 movement ("We are the teapots").
save418.com
Save Error Code 418
100
Justin Vasel @justinvasel.xyz · 21/08/2026
Okay, so this is clearly not a serious spec. Or is it? Technically, it is listed as "informational" and has not formally been adopted as a standard, but many web frameworks have worked these status codes into their libraries anyway as a treat.
100
Justin Vasel @justinvasel.xyz · 21/08/2026
Now I know what your thinking... Coffee is serious business. Is this protocol secure?? Thankfully the spec addresses that issue head on.
Anyone who gets in between me and my morning coffee should be insecure.

Unmoderated access to unprotected coffee pots from Internet users might lead to several kinds of "denial of coffee service" attacks. The improper use of filtration devices might admit trojan grounds. Filtration is not a good virus protection method."
100
Justin Vasel @justinvasel.xyz · 21/08/2026
But, tea drinkers: do not despair! RFC 7168, introduced by Imran Nazar in 2014, extends HTCPCP to support "tea efflux appliances".
rfc-editor.org
RFC 7168: The Hyper Text Coffee Pot Control Protocol for Tea Efflux Appliances (HTCPCP-TEA) | RFC Editor
The Hyper Text Coffee Pot Control Protocol (HTCPCP) specification does not allow for the brewing of tea, in all its variety and complexity. This paper outlines an extension to HTCPCP to allow for pot...
100
Justin Vasel @justinvasel.xyz · 21/08/2026
Not all coffee machines can do fancy things like add syrups, so if it can't fulfill the request it will send back a 406 Not Acceptable return code. Send your request to a teapot and you'll get back the aforementioned 418 I'm a Teapot error.
100
Justin Vasel @justinvasel.xyz · 21/08/2026
The spec allows a generous number of options for its "Accept-Addition" header, including milk, syrup, sweetener, alcohol, and spice. It does NOT provide options for decaffeinated coffee, because "what's the point?".
The Accept-Additions header fields. In HTTP, the "Accept" request-header field is used to specify media types which are acceptable for the response. However, in HTCPCP, the response may result in additional actions on the part of the automated pot. For this reason, HTCPCP adds a new header field, "Accept-Additions".

Omitted Header Fields. No options were given for decaffeinated coffee. What's the point?
100
Justin Vasel @justinvasel.xyz · 21/08/2026
In truth this was a satire about the growing trend of using HTTP as a default base from which to build more sophisticated applications.
"HTCPCP is based on HTTP. This is because HTTP is everywhere. It could not be so pervasive without being good. Therefore, HTTP is good. If you want good coffee, HTCPCP needs to be good. To make HTCPCP good, it is good to base HTCPCP on HTTP."
100
Justin Vasel @justinvasel.xyz · 21/08/2026
The rationale was simple: computerists need coffee, thus in the hyperconnected IoT-crazed world of the 1990s, where one could already make toast via SNMP, humanity needed a protocol designed "espressoly" for brewing coffee.
Documentation covering the Abstract and the Rationale and Scope of the HTCPCP protocol, which reads as follows:
"Abstract. This document describes HTCPCP, a protocol for controlling, monitoring, and diagnosing coffee pots. 

1. Rational and Scope. There is coffee all over the world. Increasingly, in a world in which computing is ubiquitous, the computists want to make coffee. Coffee brewing is an art, but the distributed intelligence of the web-connected world transcends art. Thus, there is a strong, dark, rich requirement for a protocol designed espressoly for the brewing of coffee. Coffee is brewed using coffee pots. Networked coffee pots require a control protocol if they are to be controlled.

Increasingly, home and consumer devices are being connected to the Internet. Early networking experiments demonstrated vending devices connected to the Internet for status monitoring (COKE). One of the first remotely operated machine to be hooked up to the Internet, the Internet Toaster, (controlled via SNMP) was debuted in 1990 (RFC2235). The demand for ubiquitous appliance connectivity that is causing the consumption of the IPv4 address space. Consumers want remote control of devices such as coffee pots so that they may wake up to a freshly brewed coffee, or cause coffee to be prepared at a precise time after the completion of dinner preparations."
100
Justin Vasel @justinvasel.xyz · 21/08/2026
The Hyper Text Coffee Pot Control Protocol (HTCPCP), built on top of HTTP, was published as RFC 2324 as an April Fools joke by Larry Masinter in 1998. www.rfc-editor.org/info/rfc2324/
rfc-editor.org
RFC 2324: Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0) | RFC Editor
This document describes HTCPCP, a protocol for controlling, monitoring, and diagnosing coffee pots. This memo provides information for the Internet community. It does not specify an Internet standar...
100
Justin Vasel @justinvasel.xyz · 21/08/2026
Everyone knows 404 Not Found or 403 Forbidden, but are you aware of 418 I'm a Teapot? 🫖🧵
Screenshot of RFC 2324 (HTCPCP/1.0), 1 April 1998, page 4, showing section 2.3.2 defining the "418 I'm a teapot" error code as "Any attempt to brew coffee with a teapot should result in the error code '418 I'm a teapot'. The resulting entity body MAY be short and stout."
120
Justin Vasel @justinvasel.xyz · 21/08/2026
It's even prettier in person! ♥️🤍 #16-0 #IndianaUniversity
A man in a light green blazer smiles for a selfie beside the College Football Playoff National Championship Trophy, which sits on a red-and-white striped table in front of an Indiana University banner and a First Financial Bank backdrop.
010
Justin Vasel @justinvasel.xyz · 21/08/2026
Glad to see calls for accountability growing throughout the IU community.
ipm.org
Concerned Scientists at IUB call for the removal of IU Trustee Sage Steele
The letter calls upon Gov. Mike Braun and the Board of Trustees to follow “its own code of conduct” and remove Sage Steele.
040
Reposted by Justin Vasel
Internet Archive @archive.org · 20/08/2026
📻 On National Radio Day, we celebrate the deep history of radio. From pulp heroes to breaking news to ham radio enthusiasts, it's a medium built for community. 📡 Tune into radio history in our collections: archive.org/details/oldt... #NationalRadioDay
Cover of Radio News magazine's September "Special Tube Data Issue," priced 25 cents. A large Art Deco-style vacuum tube in blue, yellow, and orange dominates the red cover. Headlines read "An Untuned R.F. Coupler for Screen-Grid Tubes," "The 1930 Amateur Regulations," "How to Judge Tubes," and "Complete Tabulation of Tube Characteristics." Signed by artist David Hymes.
218957
Reposted by Justin Vasel
Maxwell Yezpitelok @mrmxy.bsky.social · 19/08/2026
"If you don't use AI you'll get left behind" Brother I've sent emails from a Super Nintendo, I fucking love getting left behind
Photo of a CRT monitor next to a Super Famicom console with an XBAND modem inserted. The monitor's screen shows the XBAND's email composing screen. The message being composed has the subject line "I'm writing from a snes :00" and is addressed at a user named "フフフ".Screenshot of the email composing screen from the previous photo.Screenshot of the bsnes-plus Super Nintendo emulator open on Ubuntu. The game loaded is identified as "X-Band Modem BIOS (J)" and the emulator window shows the XBAND email inbox screen. There are two emails: one from user "mrmxy" with the subject line "i'm writing from a snes :0" and one from "System" with the subject line "Welcome!!" Behind the emulator window is a terminal window showing the emulator's log (indicating emulated modem activity) and a file explorer window with some Super Nintendo ROMs and save files.The bsnes-plus emulator's window now shows the content of the email, which reads (beside a profile image of an ape with sunglasses):

mrmxy 
住所 Earth, Solar System
送信日 2023.6.17
タイトル im writing from a snes :00
121154317
Justin Vasel @justinvasel.xyz · 18/08/2026
The letter I posted last week about Trustee Sage Steele is running as an oped in the Indianapolis Star today. Please share with fellow Hoosiers, and consider sending an email of your own to the IU President and Trustees if you believe this behavior demands an official university response.
indystar.com
Sage Steele's waterboarding fantasy dishonors Indiana University | Opinion
Sage Steele helped adopt Indiana University's principles on civic discourse. Her social media post about Anthony Fauci violated those standards.
020
Justin Vasel @justinvasel.xyz · 15/08/2026
Let's gooo
A theater sign for Cat Video Fest 2026 which reads "Theater 7. Starts at 11:15"
000
Justin Vasel @justinvasel.xyz · 14/08/2026
Got my tickets, tomorrow's gonna be a good day!
100
Justin Vasel @justinvasel.xyz · 14/08/2026
Tired: The Odyssey Wired: Spiderman Inspired: Cat Video Fest 2026
youtube.com
Cat Video Fest 2026 Official Trailer
YouTube video by WJCT Public Media
100
Justin Vasel @justinvasel.xyz · 14/08/2026
lmao boom for whom?
Screenshot of an article from the Wall Street Journal with the headline "The Jobless Boom Has Arrived"
000
Reposted by Justin Vasel
Randall Munroe @xkcd.com · 14/08/2026
Geology Building xkcd.com/3284/
Comic. [A college building labeled “Department of Geology” with a diagonal slash through center making it look uneven.] [caption] The administration regretted giving the geology department free rein to design their new building.
593908492
Reposted by Justin Vasel
Sam Rose @samwho.dev · 13/08/2026
This might be the most beautiful thing I've read in my life. What a privilege to be alive in 2026. ordinaryabundance.com
ordinaryabundance.com
Ordinary Abundance
A walk through a modern apartment, through the eyes of the people for whom everything in it was new.
13593221
Reposted by Justin Vasel
Justin Vasel @justinvasel.xyz · 12/08/2026
Today I sent an open letter to IU Board Chair David Hormuth and IU President Whitten about a post by Trustee Sage Steele, in which she publicly mused about torturing a named public figure and asked who wanted to join her. I am calling on IU leadership to say publicly that this is not who we are.
Screenshot of letter, page 1. There is too much text to fit within the character limit of this alt text. You can find a link to the PDF version of this letter in the next post of this thread.Screenshot of letter, page 2. There is too much text to fit within the character limit of this alt text. You can find a link to the PDF version of this letter in the next post of this thread.
311
Justin Vasel @justinvasel.xyz · 12/08/2026
You can access the PDF version of the letter here: bloomdocs.org/wp-content/u...
000
Justin Vasel @justinvasel.xyz · 12/08/2026
Today I sent an open letter to IU Board Chair David Hormuth and IU President Whitten about a post by Trustee Sage Steele, in which she publicly mused about torturing a named public figure and asked who wanted to join her. I am calling on IU leadership to say publicly that this is not who we are.
Screenshot of letter, page 1. There is too much text to fit within the character limit of this alt text. You can find a link to the PDF version of this letter in the next post of this thread.Screenshot of letter, page 2. There is too much text to fit within the character limit of this alt text. You can find a link to the PDF version of this letter in the next post of this thread.
311
Justin Vasel @justinvasel.xyz · 11/08/2026
I'm absolutely floored seeing a Trustee of Indiana University openly fantasize about torturing another human. This is abhorrent and shameful behavior, and IU should condemn it unequivocally.
Screenshot of a Twitter retweet. The original tweet is from the New York Post and depicts a photo of Anthony Fauci sitting during his recent Senate testimony. The text reads "Fauci privately warned of miscarriage risk linked to COVID vaccine while publicly claiming no issues, newly released texts show". That post was retweeted by Sage Steele (@sagesteele) who wrote "Where do I go to get permission to waterboard this man?? As he hangs upside by his toes, of course. Anyone wanna join me?"
164
Justin Vasel @justinvasel.xyz · 06/08/2026
Ah yes, the infamous Trojan Pachanga
A horse-sized-and-then-some sculpture of a blocky cartoon horse standing in a large open lobby with dark paneled walls. Its body is clad in overlapping planks with a weathered wood look, painted in fading bands of orange, teal, yellow and green. Short V-shaped notches are cut all over the boards, giving it the fringed look of a piñata rendered in lumber. A round disc on its head serves as an eye. It stands on a patch of artificial turf, roped off with blue stanchions. To the right is a standee for The Odyssey: a row of armored warriors lit in cold blue, with a cloaked figure holding a sword walking between them. Text below reads "A film by Christopher Nolan / THE ODYSSEY / 07.17.26 / Shot entirely with IMAX film cameras."Can label art for Sun King Brewery's Pachanga. On a white background, a red block at top holds the Sun King Brewery logo. Below it, "PACHANGA" in chunky black hand-lettered capitals, flanked by small red diamonds. In the center, an illustration of a donkey-shaped piñata built from segments of fringed paper in red, blue, yellow and green, with one big cartoon eye. A blue banner across the bottom reads "Mexican-Style Lager."
000
Reposted by Justin Vasel
Brendel @brendelbored.bsky.social · 03/08/2026
It’s hard to explain but tv was better when you couldn’t watch the show you wanted whenever you wanted to watch it and most of the shows were worse and the TVs were worse and the entire experience was worse, that’s when it was better
430124451643
Justin Vasel @justinvasel.xyz · 01/08/2026
Had to get a closer look 🤩
A large Delta airplane parked at the gate with the LA28 Olympics livery. The livery features a gradient from pinkish-red above the wings to dark blue near the tail. The logo for LA28 is in white block letters. Except for the "A", which is replaced by the Delta logo.A large Delta airplane parked at the gate with the LA28 Olympics livery. The livery features a gradient from pinkish-red above the wings to dark blue near the tail. The logo for LA28 is in white block letters. Except for the "A", which is replaced by the Delta logo.
000
Justin Vasel @justinvasel.xyz · 01/08/2026
Long layover at Detroit (KDTW) and nearly spit out my beer when I saw this one casually taxiing by #AvGeek
Through the large windows of the airport. A large Delta airplane with the LA28 Olympics livery taxis by. The livery features a gradient from pinkish-red above the wings to dark blue near the tail. The logo for LA28 is in white block letters. Except for the "A", which is replaced by the Delta logo.
100
Justin Vasel @justinvasel.xyz · 01/08/2026
brb time traveling back to 2024 so I can vote in the Anchorage mayoral election
A green political campaign banner attached to a chain link fence with a portrait of a dog (a husky?) next to the words "The choice is clear! Write in Meiko for Mayor 24!"
020