Sign in

James Smith 💾

@floppy.org.uk
84 followers 2 following 1.7K posts

Generic humanoid carbon unit, self-hosting media node. ❤️ tech, democracy, environment, society. Instantiated @ 332ppm. Currently building @manyfold and site admin […] 🌉 bridged from ⁂ mastodon.me.uk/@Floppy, follow @ap.brid.gy to interact

PostsRepliesMedia
James Smith 💾 @floppy.org.uk · 29/09/2026
When I interviewed at dxw (at the time a Rails shop), one question was "name something you disagree with DHH on". Nowadays, that would be a much easier question, but at the time my answer was "no idea, I generally don't pay him any attention", followed by "oh, no, wait; RSpec - fuck Test::Unit".
121
James Smith 💾 @floppy.org.uk · 29/09/2026
After two days of fiddling around getting @mosscap tests working, I maintain my position that `minitest` is a goddamn mess and that `rspec` is superior by far.
211
James Smith 💾 @floppy.org.uk · 29/09/2026
@pikesley I 💥 speak 💥 for 💥 the 💥 trees 💥 motherfucker 💥
102
James Smith 💾 @floppy.org.uk · 27/09/2026
Mastodon admins - I've popped a couple of feature requests in for mail domain and IP geolocation checking for account moderation. Both would need to be opt-in as third party services would be needed, but they'd make signup moderation a lot easier! Add a +1 or a comment if they sound useful (or […]
mastodon.me.uk
Original post on mastodon.me.uk
001
James Smith 💾 @floppy.org.uk · 27/09/2026
RE: hoosier.social/@brian/1172880020446… This is genius, just done it on this server. Should cut down the current admin from this latest stupid spamwave.
000
James Smith 💾 @floppy.org.uk · 25/09/2026
#MastodonMeUkMeta Search hasn't been working recently, but now with help from @beasts we've worked out why and fixed it. It's reindexing now, so it should be better in a few hours. Apologies for the inconvenience!
000
James Smith 💾 @floppy.org.uk · 23/09/2026
HAHAHAHA HAHAHAHAHHAAHAA HAHAHAHA HAHAHAHA HAHA HAHAHAHAHA HAHAHA HAHAH AHAHAHAHAHAHAH <gasp> AHAHAHAH AHAHAH HAHAHHAHAHAHHAHAHAHAHAHAHA AAHAHAHHAHAHAHAHAH HAHAHAHHA <gasp> “SI” <gasp> HAHHAHAHAHAHAHAH HAHAHAHAHAH HAHAHAHAH
001
James Smith 💾 @floppy.org.uk · 23/09/2026
With the Rails 8.2 release imminent, real work is about to ramp up on @mosscap, the fork we've been laying the groundwork for. If you want to help reduce the impact of the "weird guys" on Rails, Ruby and OSS in general, we need your help! This is ESPECIALLY true if you're a member of a […]
mastodon.me.uk
Original post on mastodon.me.uk
002
James Smith 💾 @floppy.org.uk · 22/09/2026
I miss the Nicole the Fediverse Chick, at least she wanted to connect, these days the robots just want to automatically probe your protocol delivery. #ModLife
000
James Smith 💾 @floppy.org.uk · 22/09/2026
@bruces it took me quite a few listens before I could handle it while working. It's... highly distracting, to say the least.
000
Reposted by James Smith 💾
manyfold.app @manyfold.app · 22/09/2026
🎉 Manyfold v0.150.0 is out, with a load of security fixes; if you're running a public server, you'll want to update! There's also support for the modern Prusa printer API. 🗞️ Full release notes: manyfold.app/news/2026/09/22/releas… 🌍️️️️️️ Join a public server […]
3dp.chat
Original post on 3dp.chat
012
Reposted by James Smith 💾
Fedipub @fedipub.dev · 22/09/2026
Fedipub v0.10.0 is out, with support for RFC9421 message signatures, so now your Rails ActivityPubapps can be more secure - and no code changes required! fedipub.dev/2026/09/22/rfc-9421-in-…
fedipub.dev
RFC9421 support in Fedipub | Fedipub
Fedipub is an Activitypub gem for Ruby applications, including a Rails engine.
001
James Smith 💾 @floppy.org.uk · 22/09/2026
the cruffatin liveth
000
James Smith 💾 @floppy.org.uk · 21/09/2026
@zzt I wonder if any papers have only been authorsed by "al"
001
James Smith 💾 @floppy.org.uk · 21/09/2026
Think I'm going to institute a new policy on the Manyfold codebase - anyone (or more likely any*thing*) explicitly asking for a CVE ID to be issued on a security report is going to get banned from the repo.
001
James Smith 💾 @floppy.org.uk · 21/09/2026
@DamonHD could have been that then! Weird noises are normally foxes, in my experience.
001
James Smith 💾 @floppy.org.uk · 21/09/2026
I'll automate your protocol deliverability probe right into the fucking sea, my son
200
James Smith 💾 @floppy.org.uk · 21/09/2026
still, good time to debug some ActivityPub, right, I'm sure that'll be fine
000
James Smith 💾 @floppy.org.uk · 21/09/2026
Woken up last night at 3am by *something* making a hideous noise outside my window, like a lion throwing up or something. Absolutely no sign of anything though. Only evidence is the fact that I'm *shattered* this morning and can hardly see straight.
200
James Smith 💾 @floppy.org.uk · 19/09/2026
Oh, YES. Been meaning to do this for years, and finally found which old box the disks were in.
A white square shadow box frame with a white background. On the background are mounted four black 3.5” floppy disks bearing the DOOM logo and “Disk X of 4”
0218
James Smith 💾 @floppy.org.uk · 19/09/2026
Got my new shirt ready for all the AI meet-ups that I don’t go to.
A red T-shirt with white text: “I strongly feel that this is an insult to life itself - Hayao Miyazaki”
113
James Smith 💾 @floppy.org.uk · 18/09/2026
Excellent point here - LLMs are not becoming more intelligent than us by actually improving, they're just doing it by making us stupider 😆 www.netmeister.org/blog/everybodys-…
netmeister.org
Everybody's Lost Their Minds
Comments
000
James Smith 💾 @floppy.org.uk · 17/09/2026
YEEES!! Last Train to Trancentral! WOO WOOOO #TheKLF #6Music #TShirtDay
000
James Smith 💾 @floppy.org.uk · 17/09/2026
@dansup @gargron is this done as an interactionPolicy, like quote permissions?
100
James Smith 💾 @floppy.org.uk · 17/09/2026
I'm interested in parallels; has any industry ever marketed itself before by causing a scare and saying "won't someone please stop us"?
011
James Smith 💾 @floppy.org.uk · 17/09/2026
@dansup NO HAMMERS ALLOWED
000
James Smith 💾 @floppy.org.uk · 17/09/2026
@pikesley I’ll pump your bubble right into the sea, my son
000
James Smith 💾 @floppy.org.uk · 17/09/2026
Appropriately, I am both Justified *and* Ancient #6music #TShirtDay
Me wearing a white T-shirt with the KLF logo on the front in black
220
James Smith 💾 @floppy.org.uk · 17/09/2026
@pikesley what the fuck was the point of that news item exactly?
100
James Smith 💾 @floppy.org.uk · 16/09/2026
Debugging HTTP signatures was the most hateful part of my initial ActivityPub work, and now I've thrown myself in it again with RFC9421. Why did I start this?
001
James Smith 💾 @floppy.org.uk · 15/09/2026
@aintnorulesays do not be on fire.
000
James Smith 💾 @floppy.org.uk · 15/09/2026
or was it RFC9241 "CDNI Footprint and Capabilities Advertisement Using ALTO"? www.rfc-editor.org/rfc/rfc9241.html or perhaps RFC9214 "OSPFv3 Code Point for MPLS LSP Ping"? www.rfc-editor.org/rfc/rfc9214.html I'll just do them all to be safe.
rfc-editor.org
RFC 9241: Content Delivery Network Interconnection (CDNI) Footprint and Capabilities Advertisement Using Application-Layer Traffic Optimization (ALTO)
The Content Delivery Networks Interconnection (CDNI) framework in RFC 6707 defines a set of protocols to interconnect CDNs to achieve multiple goals, including extending the reach of a given CDN. A CDNI Request Routing Footprint & Capabilities Advertisement interface (FCI) is needed to achieve the goals of a CDNI. RFC 8008 defines the FCI semantics and provides guidelines on the FCI protocol, but the exact protocol is not specified. This document defines a new Application-Layer Traffic Optimization (ALTO) service, called "CDNI Advertisement Service", that provides an implementation of the FCI, following the guidelines defined in RFC 8008.
000
James Smith 💾 @floppy.org.uk · 15/09/2026
Dunno why @evan is so obsessed with fediverse apps implementing RFC2941, who needs telnet authentication these days? www.rfc-editor.org/rfc/rfc2941.html
111
James Smith 💾 @floppy.org.uk · 14/09/2026
@evan yeah, I expect that’s what I’ll be doing tomorrow.
000
James Smith 💾 @floppy.org.uk · 14/09/2026
@evan given that this is a library, it *might* be possible to write a validator app once I know this one works. But no promises, my todo list is very long!
100
James Smith 💾 @floppy.org.uk · 14/09/2026
@evan righto, then I guess we're testing in production!!
A cat walking away from an explostion, with the meme text "WORKED FINE IN DEV, OPS PROBLEM NOW"
101
James Smith 💾 @floppy.org.uk · 14/09/2026
@evan RFC9421 code on @fedipub complete! Just need to test it a bit then it'll be ready to release. Do you know any ways to test that signatures are compliant, and that things can communicate properly? (Other than just trying to talk to a production Mastodon server and hoping for the best)
100
James Smith 💾 @floppy.org.uk · 14/09/2026
"approximately spherical chicken with unit vector legs" There's still some good stuff to be found on Stack Exchange... physics.stackexchange.com/questions…
000
James Smith 💾 @floppy.org.uk · 13/09/2026
I was inspired by whatever the latest round of AI bullshit is to add a new shirt to #HTTPShirts... sellshirts.com/product/23563
A red tshirt with white text reading "I strongly feel that this is an insult to life itself - Hayao Miyazaki"
023
James Smith 💾 @floppy.org.uk · 12/09/2026
@mavu so it seems.
000
James Smith 💾 @floppy.org.uk · 12/09/2026
I can’t help but be gratified at all the pushback DHH and his fash buddies are getting over Omarchy. I don’t know if it goes beyond the Fediverse (and don’t really care) but I’m glad that other people are joining the fight, even if the Rails team still don’t give a shit.
112
Reposted by James Smith 💾
Brennan Kenneth Brown @brennan.social.lol.ap.brid.gy · 11/09/2026
Decided to make a dedicated page for this. stopomarchy.neocities.org
stopomarchy.neocities.org
STOP OMARCHY: Boycott Tech's Far-Right Backers
Protest against the Omarchy/Omacom Foundation and the tech companies and executives funding far-right open source.
614106
James Smith 💾 @floppy.org.uk · 11/09/2026
@davidgerard the apostrophe here leaves me wholly unsurprised.
A stream screenshot with the text “SEE GAME’S THAT USED AI TO CREATE ARTWORK”
110
James Smith 💾 @floppy.org.uk · 11/09/2026
Crap, the tilt limiter cam on my ancient Aeron chair has broken, and I've not been able to find an existing design for a printable replacement. Might have to finally learn @freecad, although it'll be difficult in my very *very* reclined position.
001
James Smith 💾 @floppy.org.uk · 11/09/2026
@TenebrisNox I'd say if you *know* it to be false, stop reading, otherwise get the salt pinches out for the rest.
000
James Smith 💾 @floppy.org.uk · 10/09/2026
@JonRowe huh! Good business to be in at the minute then.
000
James Smith 💾 @floppy.org.uk · 10/09/2026
TIL that the UK PSTN is being fully turned off in January! I assume BT are going to make a killing selling off all the copper. www.gov.uk/guidance/uk-transition-f…
gov.uk
UK transition from analogue to digital landlines
What the retirement of analogue phone lines, also known as the Public Switched Telephone Network (PSTN), means for you.
101
James Smith 💾 @floppy.org.uk · 09/09/2026
But will I be able to follow `draft-cavage-http-signatures-12` if I haven't seen the previous 11 movies?
000
James Smith 💾 @floppy.org.uk · 09/09/2026
"If I'd had more time I'd have written less code" quoteinvestigator.com/2012/04/28/sh…
020
James Smith 💾 @floppy.org.uk · 09/09/2026
@c @ethicalsource couldn't agree more!
000