Mingwei @mingwei.bsky.social · 21/09/2026Went all-in on deepseek flash since a few weeks ago, and this is as far as i can push for the usage (being on parental leave tied my hands a bit). It's more than good enough for my use cases. 000
Mingwei @mingwei.bsky.social · 13/09/2026The best feature of my garmin watch is that flashlight. It’s so damn useful 000
Mingwei @mingwei.bsky.social · 11/09/2026I am pushing deepseek v4.1 flash with my Hermes real hard. can't possibly see it cross my $5 bar. 000
Mingwei @mingwei.bsky.social · 04/09/2026I’m very fluent at changing car key batteries. This will be my career safety net. 000
Reposted by MingweiBGPKIT @bgpkit.com · 01/09/2026Here is a close look at the recent #BGP hijack event that involves both hijacking BGP prefixes and also creating certificates during the hijack period to pretend being the true website origin with correct certs. bgpkit.com/blog/virtual...bgpkit.comAnatomy of the Virtualizor BGP Hijack: Reading the Attack in Raw BGP BytesHow AS62390 hijacked Hetzner's 162.55.80.0/24 to poison Virtualizor's update pipeline, reconstructed message-by-message from public MRT data, and why the hijacked route was RPKI-valid by design. 111
Mingwei @mingwei.bsky.social · 01/09/2026I received $0.01 dividend from my stock account. What should I do with that money? 120
Reposted by MingweiBGPKIT @bgpkit.com · 16/08/2026bgpkit-parser 0.20.0 released! Corrupted MRT files can be salvaged with opt-in recovery iterators, parse errors keep the raw bytes for diagnosis, and it parses Cisco/Quagga text dumps directly. remote MRT reads can resume after dropped connections. github.com/bgpkit/bgpki...github.comRelease v0.20.0 · bgpkit/bgpkit-parserBreaking changes Fallible encoding (#313): all encode paths now return Result<_, EncodingError> instead of silently truncating values that do not fit their wire-format fields. There are no panick... 011
Reposted by MingweiAT Protocol Developers @atproto.com · 13/08/2026Today we’re launching Bluesky Protocol Services, a new brand and website for the infrastructure Bluesky operates. And Jetstream v2, the best way for developers to use atproto at scale, now with network replay. atproto.com/blog/introdu...atproto.comIntroducing Bluesky Protocol ServicesA new home for the infrastructure Bluesky runs on the open network — including Jetstream v2 with network replay, a new Jetstream SDK, and a lex-based TypeScript SDK 28535151
Mingwei @mingwei.bsky.social · 12/08/2026A review of this PR takes DeepSeek V4 Pro 1.6M tokens with 93% cache hit rate and 6 cent ($0.06). github.com/bgpkit/bgpki... 000
Reposted by MingweiBluesky @bsky.app · 10/08/2026v1.130 is live! Want to follow someone for their posts but not their reposts? Now you can — turn on "Hide reposts in feeds" for any account you follow. 49596132398
Mingwei @mingwei.bsky.social · 07/08/2026it's effectively free no matter how hard i try to use it. 000
Mingwei @mingwei.bsky.social · 29/07/2026I’m glad that I’ve done most of my hard coding and debugging sessions before the age of agentic coding. I don’t know if I’d still learn anything if I redo all the work again now with my current coding habits. 020
Mingwei @mingwei.bsky.social · 27/07/2026The entire business revenue for instagram is hinged on users accidentally clicked on ads 111
Mingwei @mingwei.bsky.social · 24/07/2026I can’t believe I just discovered Castle Rock. Bill Skarskard is terrifying. 000
Reposted by MingweiBGPKIT @bgpkit.com · 11/07/2026🚀 bgpkit-parser 0.18.0 released: improved raw BGP attribute data preservation, better RIS Live raw message parsing support, and typed parsers for four more recent RFCs. bgpkit.com/blog/bgpkit-...bgpkit.combgpkit-parser 0.18.0 Releasebgpkit-parser 0.18.0 preserves more raw BGP wire data, parses RIS Live raw messages, and adds typed parsers for AIGP, SFP, BFD Discriminator, BGP Prefix-SID, and BIER attributes. 011
Mingwei @mingwei.bsky.social · 07/07/2026I had two UPS failed on my at home today. It was potentially caused by a house electricity surge. as a result I realized I have been running two old non-functioning UPS for sometime 😞 I wish UPSs have health checks warnings, but that would probably break my wallet. 010
Mingwei @mingwei.bsky.social · 04/07/2026I bought one because I bought metal gear 3 with disc but then realized the ps5 pro doesn’t come with a disc drive. Now the disc drive is sold out. 000
Mingwei @mingwei.bsky.social · 01/07/2026I truly do not understand why The Tainted Cup has such high reviews. 000
Mingwei @mingwei.bsky.social · 28/06/2026I’ve watched a open box instruction video of the PortaSplit. The attention to details is great 000
Reposted by MingweiBGPKIT @bgpkit.com · 25/06/2026New blog post: Finding Well-Known BGP Communities with monocle bgpkit.com/blog/well-kn...bgpkit.comFinding Well-Known BGP Communities with monocleAn ad-hoc, reproducible analysis for scanning public MRT updates for BGP communities, joining them with the IANA registry, and checking behavior against RFC text. 011
Mingwei @mingwei.bsky.social · 25/06/2026Check out the fancy atproto meta data (standard.site) I configured for my site 😬 bgpkit.com/blog/investi...bgpkit.comInvestigating the India–Telegram BGP Hijack with monocleA step-by-step forensic investigation of the June 2026 Telegram BGP hijack using monocle and the BGPKIT API - public data, real commands, real output. 110
Mingwei @mingwei.bsky.social · 25/06/2026Some projects releasing major versions faster than my bug fixes. It’s really a different mindset when it comes to semantic versioning. 000
Mingwei @mingwei.bsky.social · 25/06/2026Just discovered and finished the amazing digital circus. Holy shit it is good 000
Reposted by MingweiBGPKIT @bgpkit.com · 22/06/2026New blog: Investigating the India–Telegram #BGP Hijack with monocle bgpkit.com/blog/investi...bgpkit.comInvestigating the India–Telegram BGP Hijack with monocle - BGPKITA step-by-step forensic investigation of the June 2026 Telegram BGP hijack using monocle and the BGPKIT API - public data, real commands, real output. 001
Reposted by MingweiJason Lengstorf @jason.energy · 13/06/2026I started writing one thing and got off on this tangent so now I guess there are two things? anyways atproto feels special in a way I tried to put into wordscodetv.devI am very excited about AT ProtocolAT Protocol (atproto) is the right mix of useful, practical, personal, and fun. I think it could save the internet. 516920
Mingwei @mingwei.bsky.social · 03/06/2026Just renewed by subscription for DEVONthink for another 3 years. Great local-first but also AI-capable app developed by @devontechnologies.bsky.social since 2002! 010
Reposted by MingweiBGPKIT @bgpkit.com · 28/05/2026🚀 monocle v1.3.0 is out. New: monocle rib command that reconstructs #BGP RIB state at any timestamp. Load the latest RIB dump, replay overlapping updates, and see exactly what each peer was advertising at that moment. blog.bgpkit.com/monocle-v1-3...blog.bgpkit.com 011
Reposted by MingweiBGPKIT @bgpkit.com · 24/05/2026🚀 bgpkit-parser v0.17.0: github.com/bgpkit/bgpkit-parser/releases/tag/v0.17.0 New: route-level into_route_iter() for ~50-70% faster RIB scans, MPLS Labeled NLRI parsing (RFC 3107/8277), and BMP RFC 9515/9736/9972 support. Plus smallvec AS Path optimization and attribute validation (RFC 4760).github.comRelease v0.17.0 · bgpkit/bgpkit-parserNew features Minimal route-level parser: Added BgpRouteElem and into_route_iter() / into_fallible_route_iter() for fast scans when only prefix, AS path, peer metadata, and timestamp are needed (t... 011
Mingwei @mingwei.bsky.social · 22/05/2026@devontechnologies.bsky.social DEVONthink's new MCP server is awesome. I can finally use my local agent to work with files in DEVONthink and properly use it as my knowledge management tool. 182
Reposted by MingweiDavid Belson @dbelson.com · 08/05/2026I was one of the 1100 impacted by yesterday's layoff at Cloudflare. Thankful that I had the opportunity to work on @radar.cloudflare.com over the past 4+ years, evolving it into a trusted industry resource. Would love to continue working with #Internet data in my next role... 1227
Mingwei @mingwei.bsky.social · 10/04/2026Opus is infuriatingly lazy and incompetent these few days. 110