Sign in

Nick Buraglio

@forwardingplane.net
479 followers 102 following 122 posts

Sometimes I do computer networking or security things. I like IPv6.

PostsRepliesMedia
Nick Buraglio @forwardingplane.net · 26/09/2026
#audio folks of bluesky - I am rebuilding an audio system after a couple of decades of not playing physical media. We have a lot of cassettes, records, and CDs. I have a decent sony CD player. Looking for recommendations on turntable, tuner/amp, cassette deck. Not opposed to vintage.
010
Reposted by Nick Buraglio
Jason Gintert @bitsinflight.com · 23/09/2026
David Huberman from ICANN shared at #ABQNOG that the DNS root KSK rollover is October 11. Running a DNSSEC-validating resolver? Confirm KSK-2024 (key tag 38696) is in your trust anchors if not, every query SERVFAILs. Not the DNS gal or guy? Pass this along! www.icann.org/resources/pa...
163
Nick Buraglio @forwardingplane.net · 30/08/2026
A bit of a labor of love for me, this #movie trailer streaming site scratches my early 90s video store clerk nostalgia itch. I enjoy letting it simply play in the background. Most of the content is from @archive.org, so if you like it please consider donating to them. www.videofeatures.net
videofeatures.net
Coming Attractions
000
Nick Buraglio @forwardingplane.net · 27/07/2026
Ever wanted to run reasonable baseline performance tools on resource constrained hosts? Me too. In the vein of perfsonar - github.com/retecolo/pic...
github.com
GitHub - retecolo/piccolo-perf: A performance test suite designed for resource constrained environments
A performance test suite designed for resource constrained environments - retecolo/piccolo-perf
000
Nick Buraglio @forwardingplane.net · 12/07/2026
New and *vastly* improved version of tiny-twamp is now available github.com/buraglio/tin... New features include actual RFC compliance with twamp-light (RFC 5637 §5), prometheus export, influxdb support, and a whole new binary release system. #latency #measurement #twamp
0100
Nick Buraglio @forwardingplane.net · 08/07/2026
More information: it looks like there may be a possible issue with how the client iterates through a candidate list as v4, v6, v4, v6, but stops at the first success. Could be a problem for some NAT64 clients. Swapping the order might help, would follow RFC6724, and should use IPv6 when available.
091
Nick Buraglio @forwardingplane.net · 07/07/2026
Anyone have any insight on this behavior with the @tailscale.com client? I can't seem to replicate it with tailscale service, but it's really easy to reproduce with headscale. It *looks* like a client issue, but I'm still trying to understand the whole picture github.com/juanfont/hea...
101
Nick Buraglio @forwardingplane.net · 27/05/2026
Also check out my ARIN 57 keynote about - you guessed it - #IPv6 www.arin.net/blog/2026/05...
arin.net
The Nine Lives of an Early Adopter: ESnet’s IPv6 Journey — and Why It Matters Now
Last month's ARIN 57 meeting featured a keynote address that brought three decades of real-world IPv6 experience to bear on the question the Internet community keeps asking: Are we there yet? Learn ho...
033
Nick Buraglio @forwardingplane.net · 27/05/2026
I'll be giving a talk at @chinog.bsky.social tomorrow (28-May) about why should care about #IPv6. Stop by if you're around!
010
Nick Buraglio @forwardingplane.net · 27/05/2026
2/2 Of course this can mostly kinda/sorta be worked around with CLAT and DNS64, but on containerization hosts that is less so, and more complexity than is necessary. come on, GitHub. Your IPv6 readiness and the windows CLAT are the in the last few big pieces.
020
Nick Buraglio @forwardingplane.net · 27/05/2026
More and more I am finding that the single largest technical impediment to #IPv6 deployment is the fact that #Github has no IPv6. Lack of an IPv6 endpoint not only hinders development work, it really makes working with containerization images and platforms almost prohibitively frustrating. 1/2
140
Nick Buraglio @forwardingplane.net · 29/03/2026
We’ve been playing out for a couple of years now. The other dudes are quite talented and have been in lots of bands. We opened for DRI at Reggie’s in Chicago last may.
000
Nick Buraglio @forwardingplane.net · 29/03/2026
And as an arguably old man once again a vocalist for a punk / thrash band, I’m channeling it.
110
Nick Buraglio @forwardingplane.net · 29/03/2026
100%. For once I’m ahead of you on something.
010
Nick Buraglio @forwardingplane.net · 29/03/2026
Jim did the hard work. All credit to his tireless effort to keep track of this often unpublished or hard-to-find tech detail for so many years. I have an archive of his site, too, if anyone wants it. It's also on archive.org. Still adding more detail as I can scrape it or it gets submitted.
000
Nick Buraglio @forwardingplane.net · 29/03/2026
In keeping with his tradition and to help the community, I have mirrored and expanded the site with significantly more platforms and chipsets. port-buffers.forwardingplane.net #neteng #networkengineering
port-buffers.forwardingplane.net
Packet Buffer Reference
Packet buffer comparison table for networking switches, grouped by ASIC family
153
Nick Buraglio @forwardingplane.net · 29/03/2026
Many years ago Jim Warner started a page dedicated to documenting port buffers on network hardware. Since Jim's passing a few year ago this site has been taken down and restored a few times. people.ucsc.edu/~warner/buff...
port-buffers.forwardingplane.net
Packet Buffer Reference
Packet buffer comparison table for networking switches, grouped by ASIC family
110
Nick Buraglio @forwardingplane.net · 15/03/2026
Fairly big updates to the backend of stats.ipv6.army - integration of routeviews data to enrich BGP statistics, fix a *bunch* of really, really gross hardcoded stuff, make modular and improve data source polling logic, and added better mobile network data statistics. #ipv6 #ipv6stats
stats.ipv6.army
Streamlit
011
Nick Buraglio @forwardingplane.net · 05/03/2026
Last nights fun project was this topography mapper using LLDP and SNMP to walk networks and map them out. Generates a png, pdf, drawio diagram or a excalidraw doc. github.com/buraglio/lld...
github.com
GitHub - buraglio/lldp2map: A go utility for creating a map based on LLDP data obtained via SNMP
A go utility for creating a map based on LLDP data obtained via SNMP - buraglio/lldp2map
052
Nick Buraglio @forwardingplane.net · 24/02/2026
Features update for ipv6utils, including the "format the addressing" stuff discussed in one of the #IPv6Buzz podcasts. Also a new build system that automatically builds every binary for a given release and posts them for download and an updated brew tap for MacOS. #IPv6 github.com/buraglio/ipv...
github.com
GitHub - buraglio/ipv6utils: A command-line utility for IPv6 subnet generation and IPv4/IPv6 address translation using RFC 6052, PTR Generation, and other transcoding.
A command-line utility for IPv6 subnet generation and IPv4/IPv6 address translation using RFC 6052, PTR Generation, and other transcoding. - buraglio/ipv6utils
000
Nick Buraglio @forwardingplane.net · 15/01/2026
+1
010
Reposted by Nick Buraglio
Lou Plummer  @amerpie.lol · 15/01/2026
Today on AppAddict - Tailscale: The Best Free App Most Mac Power Users Aren’t Using - Someone asked me to name the best free app available to Mac users in 2026. I didn’t hesitate before choosing Tailscale.... appaddict.app/post/ailscale-the-bes…
The Tailscale App on my home computer
062
Nick Buraglio @forwardingplane.net · 13/01/2026
ipv6.army now supports sharing your performance results (stored for 90 days) #ipv6
ipv6.army
IPv6 is the current internet protocol.
The IPv6 Army
011
Nick Buraglio @forwardingplane.net · 12/01/2026
+1
000
Nick Buraglio @forwardingplane.net · 12/01/2026
Linux is looking for testers for their upcoming #IPv6 CLAT support in NetworkManager gitlab.freedesktop.org/NetworkManag... social.ipv6.army/@ipv6/status...
021
Nick Buraglio @forwardingplane.net · 27/12/2025
A brief assessment of mail hosting providers for 2026 www.forwardingplane.net/post/2025-12...
forwardingplane.net
Hosted email options for 2026
001
Reposted by Nick Buraglio
IPv6 & IoT @ipv6.net · 16/12/2025
Strengthening regional cooperation for an open and interoperable Internet ipv6.net/news/strengt... #IoT #IPv6 #M2M #InternetOfThings #tech #IoE #news
ipv6.net
Strengthening regional cooperation for an open and interoperable Internet - IPv6.net
APNIC Director General Jia Rong Low and staff visited Beijing for CNIRC 2025, engaging with operators, research networks, and government partners to advance practical cooperation on IPv6, routing security,...
031
Nick Buraglio @forwardingplane.net · 15/12/2025
Had a lot of fun getting back together with @ipspace.bsky.social for the triumphant return of SGW: www.forwardingplane.net/post/2025-12...
forwardingplane.net
IETF v6ops Working Group on Software Gone Wild
032
Nick Buraglio @forwardingplane.net · 08/12/2025
Embargo on.
000
Nick Buraglio @forwardingplane.net · 08/12/2025
Added a host of new features to the IPv6 performance test site at www.ipv6.army It now does an evaluation of IPv4 vs IPv6 and allows for browser locaStorage of results with trending over time. The description of tests should be quite comprehensive, as well, accounting for a bunch of nuance. #ipv6
ipv6.army
Join the IPv6 Army
Join the IPv6 Army
011
Reposted by Nick Buraglio
Scott Hogg @scotthogg.bsky.social · 18/11/2025
Windows CLAT Enters Private Preview: A Milestone for IPv6 Adoption techcommunity.microsoft.com/blog/network...
techcommunity.microsoft.com
Windows CLAT Enters Private Preview: A Milestone for IPv6 Adoption | Microsoft Community Hub
IPv6 Adoption: A Global Shift Since its standardization in the late 1990s, IPv6 has steadily gained traction. The last 15 years, especially since World IPv6...
043
Reposted by Nick Buraglio
Scott Hogg @scotthogg.bsky.social · 07/11/2025
It's not too late to register for the UK #IPv6 Council Annual Meeting November 18, 2025. BTW, It's FREE to attend! www.eventbrite.co.uk/e/uk-ipv6-co...
eventbrite.co.uk
UK IPv6 Council Annual Meeting 2025
A day-long event with various talks about the latest developments in IPv6 deployments and technology, hosted by BT in BT Tower, London.
022
Nick Buraglio @forwardingplane.net · 01/11/2025
I have 2 of these and they work great.
000
Reposted by Nick Buraglio
Kapil Agrawal @netops2devops.net · 24/10/2025
Really looking forward to this event! #kubernetes #cilium #ipv6 #kubecon
062
Nick Buraglio @forwardingplane.net · 13/10/2025
Due to the recent potential removal of test-ipv6.com, ipv6.army now supports some similar IPv6 tests to determine compatibility and efficiency. #IPv6
ipv6.army
Join the IPv6 Army
Join the IPv6 Army
012
Nick Buraglio @forwardingplane.net · 05/10/2025
End of an era
010
Nick Buraglio @forwardingplane.net · 05/10/2025
That may be helpful, thank you. There are a few sources that tend to dislike being scraped (thus why my stuff is a 30 day cache). I’ll see if the Cisco one is one of them
010
Nick Buraglio @forwardingplane.net · 04/10/2025
The #IPv6 stats site is significantly more efficient now (and pulls from @cloudflare.social RADAR instead of the old source for CF data) stats.ipv6.army
stats.ipv6.army
Streamlit
220
Nick Buraglio @forwardingplane.net · 02/10/2025
Happy to be involved with this one. Should also mention the speed with which this published. 14 months from a dinner conversation to a published document is pretty wild (12 months in data tracker time!) datatracker.ietf.org/doc/rfc9872/
datatracker.ietf.org
RFC 9872: Recommendations for Discovering IPv6 Prefix Used for IPv6 Address Synthesis
On networks providing IPv4-IPv6 translation (RFC 7915), hosts and other endpoints need to know the IPv6 prefix(es) used for translation (the NAT64 prefix (RFC 6052)). This document provides guidelines...
050
Nick Buraglio @forwardingplane.net · 11/09/2025
Sweet! Thank for the pointer.
000
Nick Buraglio @forwardingplane.net · 11/09/2025
This is super cool. Any chance you'll open source the framework?
100
Nick Buraglio @forwardingplane.net · 11/09/2025
@richardhicks.com wrote a nice piece on windows DHCP server with option 108 (IPv6-mostly). directaccess.richardhicks.com/tag/winclat/
directaccess.richardhicks.com
WinCLAT – Richard M. Hicks Consulting, Inc.
Posts about WinCLAT written by Richard M. Hicks
020
Nick Buraglio @forwardingplane.net · 06/09/2025
Had a chance to sit with @ecbanks.bsky.social over at @packetpushers.bsky.social to talk about latency. Always a good time! www.forwardingplane.net/post/2025-09...
forwardingplane.net
HN795 - Adventures In Latency
020
Nick Buraglio @forwardingplane.net · 03/09/2025
Ohhhh Im adding that to the list, too. Good call!
010
Nick Buraglio @forwardingplane.net · 18/08/2025
In the same vein as ipv6compatibility.com, I have used replit to create an aggregation service for global IPv6 statistics. The code is slightly modified to run stand-alone on my own hosting systems and is available on my github. It's still pretty beta, but it works reasonably well. stats.ipv6.army
stats.ipv6.army
Streamlit
001
Reposted by Nick Buraglio
Eugene Meidinger @sqlgene.com · 09/08/2025
Interesting complaints about the MCP "protocol". julsimon.medium.com/why-mcps-dis...
julsimon.medium.com
Why MCP’s Disregard for 40 Years of RPC Best Practices Will Burn Enterprises
Fool me once, shame on you; fool me twice, shame on me.
4188
Nick Buraglio @forwardingplane.net · 10/08/2025
"Pop quiz, hotshot." --Dennis Hopper as Howard Payne, Speed (1994) I built a quiz app in Go. It's flexible that any questions could be compiled into it, but right now it's mostly AI generated questions about #IPv6. quiz.ipv6.army
quiz.ipv6.army
IPv6 Quiz
012
Nick Buraglio @forwardingplane.net · 02/08/2025
Created a high level, basic "get your #IPv6 address plan started" app to github. It's somewhat complimentary to ipv6utils. github.com/buraglio/ipv...
github.com
GitHub - buraglio/ipv6planner: A high level IPv6 subnet planner written in go
A high level IPv6 subnet planner written in go. Contribute to buraglio/ipv6planner development by creating an account on GitHub.
051
Nick Buraglio @forwardingplane.net · 22/07/2025
We pushed out a new version of the #IPv6 textbook yesterday. This version expands on some sections and adds an ePub version for folks that want to use that format. It can be found as a free download here ipv6textbook.com For potential contributors, the repo can be found @ github.com/becarpenter/...
ipv6textbook.com
Free, OpenSource IPv6 Textbook
ipv6 textbook
032