Sign in

Nick Buraglio

@forwardingplane.dial.modem.show.ap.brid.gy
26 followers 0 following 20 posts

Networking & IT. Old guy with a skateboard & grossly inflated sense of creative ability. This stuff is my personal, worthless opinion [bridged from dial.modem.show/@forwardingplane on the fediverse by fed.brid.gy ]

PostsRepliesMedia
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 13/10/2025
Due to the recent potential removal of test-ipv6.com, www.ipv6.army now supports some similar IPv6 tests to determine compatibility and efficiency. #ipv6
ipv6.army
Join the IPv6 Army
Join the IPv6 Army
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 02/10/2025
Happy to be involved with this one. Should also mention the speed with which this published. 14 months from a dinner conversation to a published document is pretty wild (12 months in data tracker time!) datatracker.ietf.org/doc/rfc9872
datatracker.ietf.org
RFC 9872: Recommendations for Discovering IPv6 Prefix Used for IPv6 Address Synthesis
On networks providing IPv4-IPv6 translation (RFC 7915), hosts and other endpoints need to know the IPv6 prefix(es) used for translation (the NAT64 prefix (RFC 6052)). This document provides guidelines for NAT64 prefix discovery, specifically recommending obtaining the NAT64 prefix from the Router Advertisement option (RFC 8781) when available.
001
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 18/08/2025
In the same vein as ipv6compatibility.com, I have used replit to create an aggregation service for global #IPv6 statistics. The code is slightly modified to run stand-alone on my own hosting systems and is available on my github. It's still pretty beta, but it works reasonably well […]
dial.modem.show
Original post on dial.modem.show
001
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 10/08/2025
"Pop quiz, hotshot." --Dennis Hopper as Howard Payne, Speed (1994) I built a quiz app in Go. It's flexible that any questions could be compiled into it, but right now it's mostly AI generated questions about #IPv6. quiz.ipv6.army
quiz.ipv6.army
IPv6 Quiz
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 03/08/2025
Made a high level, basic "get your #IPv6 address plan started" app and posted to github. It's somewhat complimentary to ipv6utils (also on GitHub and Mac homebrew). It is pretty basic, more of a bootstrap than anything - because the first step is usually the hardest […]
dial.modem.show
Original post on dial.modem.show
001
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 17/05/2025
New post: IPv6 Buzz Podcast 175: IPv6 Basics - Link-Local Addresses www.forwardingplane.net/post/2025-0…
forwardingplane.net
IPB175 - IPv6 Basics - Link-Local Addresses
Returning with more IPv6 basics, we dive deep into that often overlooked and frequently ignored address family - link-local addresses. Link-local addresses are unicast addresses used for addressing on a single link. The intent of link-local addresses is to let devices that may not have a router or global unicast address allocation mechanism still be able to communicate on a network segment. On today’s show we dig into how link-local addresses work, what to do with them, potential issues with link-local addresses, and more.
010
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 27/03/2025
I’m coming around to Go, for whatever reason it makes more sense to me than python. 🤷 With some help (ok, quite a bit of help) the #IPv6 tools are now compiled into a go binary. Here is the webified version: tools.forwardingplane.net Much faster, more features. Seems a lot more stable.
tools.forwardingplane.net
IPv6 Subnet Planner
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 19/03/2025
An example of the webapp version of the #IPv6 planner is available at tools.forwardingplane.net It's my first (and only) flask based webapp, so I have no idea of the stability, but it does work.
tools.forwardingplane.net
IPv6 Subnet Planner
132
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 19/03/2025
I created a few tools in an effort to better acquaint myself with python. One to generate #IPv6 prefixes for address planning One to generate URL lists for use in things like pihole or other intelligence feeds, and one to take TailScale IPv6 addresses and create DNS entries for them either in […]
dial.modem.show
Original post on dial.modem.show
011
Reposted by Nick Buraglio
pvaneynd.hachyderm.io.ap.brid.gy @pvaneynd.hachyderm.io.ap.brid.gy · 01/02/2025
So #FOSDEM early afternoon update... ARP entries on dual stack 2913 DHCP entries on dual stack 3017 IPv6 entries dual stack 10195/1847 currently REACHable IPv6 entries IPv6-only 39593/6999 So at least 8846 IPv6 capable devices present Traffic picked up at ~1Gbit/s down and ~663Mbit/s upload
022
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 01/02/2025
Since modem.show is probably done as far as publishing podcasts, I am thinking of moving off of a full mastodon install onto a #gotosocial install (which I already have set up on another domain). So far it is a very straightforward platform, much more simple than a full mastodon instance. Any […]
dial.modem.show
Original post on dial.modem.show
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 20/01/2025
Is anyone that *actively runs* a mastodon instance interested in a domain I bought - neteng.social - that I had big plans to run as a public mastodon server, and then never did? I'd let someone transfer it if they agreed to use it for a *public* masto instance, and had resources and experience […]
dial.modem.show
Original post on dial.modem.show
015
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 03/01/2025
Dipping back into writing up blog posts with a host sFlow over Tailscale solution. www.forwardingplane.net/post/2025-0…
forwardingplane.net
Building a host telemetry solution using Tailscale
An often overlooked dimension of data collection is flow data from hosts. This is not a new concept, there have been tools built for this for a very long time, but in many cases, and especially over the last 8-10 years, many system engineers have gravitated toward tooling like grafana and prometheus. While these are fine tools and if done well provide an excellent view of host health, they aren’t really a full picture of host behavior.
033
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 27/12/2024
Discouraging use of RFC7050 for Discovery of IPv6 Prefix Used for IPv6 Address Synthesis Now an adopted IETF draft. datatracker.ietf.org/doc/draft-bura… #ietf #ipv6
datatracker.ietf.org
Discouraging use of RFC7050 for Discovery of IPv6 Prefix Used for IPv6 Address Synthesis
RFC7050 describes a method for detecting the presence of DNS64 and for learning the IPv6 prefix used for protocol translation (RFC7915). This methodology depends on the existence of a well-known IPv4-only fully qualified domain name "ipv4only.arpa.". Because newer methods exist that lack the requirement of a higher level protocol, instead using existing operations in the form of native router advertisements, discovery of the IPv6 prefix used for protocol translation using RFC7050 should be discouraged. RFC7050 MAY only be used if other methods (such as RFC8781]) can not be used.
012
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 21/12/2024
Since everything in @obsidian is literally markdown, & my site is built in Netlify, taking those notes & shoving them into the blog is very easy. After building what will become some public DoT / DoH resolvers, I just added my 1st post of 2024 =) […]
dial.modem.show
Original post on dial.modem.show
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 21/12/2024
Looking back on my blog (www.forwardingplane.net ), after 13+ years it has started to dwindle off. Where I found it personally most valuable was as a repository of random junk that I learned, especially as a place that forced me to organize my notes. Going through my notes (now in […]
dial.modem.show
Original post on dial.modem.show
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 08/12/2024
Frustrated and not wanting to host my own wordpress, or to pay for hosting, I moved (again) back to hugo/netlify. So many updates and tools improvements since I last tried this a few years ago. www.forwardingplane.net is now MD driven (again). Now I just need to find motivation to add […]
dial.modem.show
Original post on dial.modem.show
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 26/11/2024
New shirt day. My distressed take on an absolute classic. #metalstorm #movieart #80smovies
000
Reposted by Nick Buraglio
Library Monster @librarymonster.glammr.us.ap.brid.gy · 24/11/2024
#punk #PublicLibraries #Libraries
A person doing "rock on" hands wearing a gray t-shirt with different chunky fonts for each letter saying "what's more punk than the public library?????"
0116
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 25/11/2024
I'm looking for a summer intern to work on testing and evaluating the options and performance of CLAT across platforms. #IPv6 jobs.lbl.gov/jobs/student-assistant…
000
Nick Buraglio @forwardingplane.dial.modem.show.ap.brid.gy · 20/11/2024
A few of us want to promote use of pref64 for IPv6-only. We wrote a draft to help. Eyeballs and input from practitioners would be useful . Let’s exercise this new momentum on non-x-sites. datatracker.ietf.org/doc/html/draft… #ipv6 #ipv6only
003